summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2017-06-13 22:58:04 +0200
committerPhilipp Wolfer2017-06-13 22:58:04 +0200
commitc8727f3716745fe6e10c10f2dd0585a12d811b73 (patch)
treef43e8978f0df536dc87fbc2f6e41d5a765acbc88
parentdae3597755d1fc4d0e37345907f7bc3d7e5a9260 (diff)
downloadaur-c8727f3716745fe6e10c10f2dd0585a12d811b73.tar.gz
New upstream release 1.0.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed2ecf818533..f8a747806902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 26 15:24:22 UTC 2017
+# Tue Jun 13 20:58:04 UTC 2017
pkgbase = peek
pkgdesc = Simple animated GIF screen recorder with an easy to use interface
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/phw/peek
arch = i686
@@ -11,13 +11,14 @@ pkgbase = peek
makedepends = cmake
makedepends = vala
makedepends = gettext
+ makedepends = txt2man
depends = gtk3
depends = libkeybinder3
depends = ffmpeg
depends = imagemagick
optdepends = gst-plugins-good: WebM output under Gnome Shell
optdepends = gst-plugins-ugly: MP4 output under Gnome Shell
- source = git+https://github.com/phw/peek.git#tag=v1.0.1
+ source = git+https://github.com/phw/peek.git#tag=v1.0.2
sha1sums = SKIP
pkgname = peek
diff --git a/PKGBUILD b/PKGBUILD
index 079cc1c52c8a..bfee87e98e42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=peek
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
arch=('i686' 'x86_64')
url="https://github.com/phw/peek"
license=('GPL3')
depends=(gtk3 libkeybinder3 ffmpeg imagemagick)
-makedepends=(cmake vala gettext)
+makedepends=(cmake vala gettext txt2man)
optdepends=(
'gst-plugins-good: WebM output under Gnome Shell'
'gst-plugins-ugly: MP4 output under Gnome Shell'
)
-source=(git+https://github.com/phw/peek.git#tag=v${pkgver})
+source=(git+https://github.com/phw/${pkgname}.git#tag=v${pkgver})
sha1sums=('SKIP')
build() {
- cd "${srcdir}/peek"
+ cd "${srcdir}/${pkgname}"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=ON \
-DGSETTINGS_COMPILE=OFF .
@@ -24,11 +24,11 @@ build() {
}
check() {
- cd "${srcdir}/peek"
+ cd "${srcdir}/${pkgname}"
#make test
}
package() {
- cd "${srcdir}/peek"
+ cd "${srcdir}/${pkgname}"
make DESTDIR=${pkgdir} install
}