summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2015-12-30 10:17:35 +0100
committerPhilipp Wolfer2015-12-30 10:17:35 +0100
commite749a7b0cae6551a51579625f054939a0fef33a4 (patch)
tree4970aeda82661299509bf06a4b47f777a13641e6
downloadaur-e749a7b0cae6551a51579625f054939a0fef33a4.tar.gz
Initial version to package Peek
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD28
-rw-r--r--peek.install15
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9df7730345c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 09:17:35 UTC 2015
+pkgbase = peek
+ pkgdesc = Peek - animated GIF recorder
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/phw/peek
+ install = peek.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = gtk3
+ depends = ffmpeg
+ depends = imagemagick
+ source = git+https://github.com/phw/peek.git
+ sha1sums = SKIP
+
+pkgname = peek
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cdaf61f4f21a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+src/*
+pkg/*
+peek/*
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.zip
+*.gem
+*.air
+*.part
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306f092c0765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
+pkgname=peek
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Peek - animated GIF recorder"
+arch=('i686' 'x86_64')
+url="https://github.com/phw/peek"
+license=('GPL3')
+depends=(gtk3 ffmpeg imagemagick)
+makedepends=(cmake vala)
+install=peek.install
+source=(git+https://github.com/phw/peek.git)
+sha1sums=('SKIP')
+
+build() {
+ cd "${srcdir}/peek"
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -DGSETTINGS_COMPILE=OFF .
+ make
+}
+
+#check() {
+# cd "${srcdir}/peek"
+#}
+
+package() {
+ cd "${srcdir}/peek"
+ make install
+}
diff --git a/peek.install b/peek.install
new file mode 100644
index 000000000000..e885b42186a1
--- /dev/null
+++ b/peek.install
@@ -0,0 +1,15 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor
+ update-desktop-database -q
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor
+ update-desktop-database -q
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}