summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2018-05-07 12:23:18 +0200
committerPhilipp Wolfer2018-05-07 12:23:18 +0200
commit5cc4da62fc4f94d4ad50cf6d7ec4e1af2bc30c74 (patch)
tree3994a9b802ac5d087b8e0a0890b792f1d733c4d3
parent0863613c8822e084ed4906845745c36b16e3b5a2 (diff)
downloadaur-5cc4da62fc4f94d4ad50cf6d7ec4e1af2bc30c74.tar.gz
Build with Meson instead of CMake
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 180210a942e1..7c25f0f152b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = peek-git
pkgdesc = Simple screen recorder with an easy to use interface (latest development release)
- pkgver = 1.3.1.r0.g15966bc
+ pkgver = 1.3.1.r45.g22b9fe0
pkgrel = 1
url = https://github.com/phw/peek
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = cmake
+ makedepends = meson
makedepends = vala
makedepends = gettext
makedepends = txt2man
@@ -17,7 +17,7 @@ pkgbase = peek-git
optdepends = gst-plugins-good: Recording under Gnome Shell
optdepends = gst-plugins-ugly: MP4 output under Gnome Shell
optdepends = gifski: High quality GIF animations with thousands of colors
- provides = peek=1.3.1.r0.g15966bc
+ provides = peek=1.3.1.r45.g22b9fe0
conflicts = peek
source = git+https://github.com/phw/peek.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 60d1566a04d0..6a4d37286289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
_pkgname=peek
pkgname=${_pkgname}-git
-pkgver=1.3.1.r0.g15966bc
+pkgver=1.3.1.r45.g22b9fe0
pkgrel=1
pkgdesc="Simple screen recorder with an easy to use interface (latest development release)"
arch=('i686' 'x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
depends=(gtk3 libkeybinder3 ffmpeg)
-makedepends=(git cmake vala gettext txt2man)
+makedepends=(git meson vala gettext txt2man)
optdepends=(
'gst-plugins-good: Recording under Gnome Shell'
'gst-plugins-ugly: MP4 output under Gnome Shell'
@@ -19,29 +19,25 @@ optdepends=(
source=(git+https://github.com/phw/${_pkgname}.git)
sha1sums=('SKIP')
-prepare() {
- mkdir -p build
-}
-
build() {
- cd "build"
- cmake ${srcdir}/${_pkgname}\
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTS=ON \
- -DCMAKE_BUILD_TYPE=Release \
- -DGSETTINGS_COMPILE=OFF \
- -DENABLE_FILECHOOSERNATIVE=ON
- make
+ cd "${srcdir}/${_pkgname}"
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ -Denable-filechoosernative=true \
+ builddir
+ cd builddir
+ ninja
}
check() {
- cd "build"
- make test
+ cd "${srcdir}/${_pkgname}/builddir"
+ ninja test
}
package() {
- cd "build"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${_pkgname}/builddir"
+ DESTDIR=${pkgdir} ninja install
}
pkgver() {