summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2017-03-09 20:08:57 +0100
committerPhilipp Wolfer2017-03-09 20:08:57 +0100
commita52835436285b3fd339b410c61d140c9016bcdb9 (patch)
tree8ec4da05cdfe0bff97aa8f838093558f12a83a6d
downloadaur-a52835436285b3fd339b410c61d140c9016bcdb9.tar.gz
First version of peek-git
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD41
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f95e08777730
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Thu Mar 9 19:08:57 UTC 2017
+pkgbase = peek-git
+ pkgdesc = Simple animated GIF screen recorder with an easy to use interface (latest development release)
+ pkgver = 0.9.1.r186.g05f4355
+ pkgrel = 1
+ url = https://github.com/phw/peek
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ makedepends = gettext
+ depends = gtk3
+ depends = libkeybinder3
+ depends = ffmpeg
+ depends = imagemagick
+ optdepends = gst-plugins-good: WebM output under Gnome Shell
+ optdepends = gst-plugins-ugly: MP4 output under Gnome Shell
+ provides = peek=${pkgver}
+ conflicts = peek
+ source = git+https://github.com/phw/peek.git
+ sha1sums = SKIP
+
+pkgname = peek-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cdaf61f4f21a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+src/*
+pkg/*
+peek/*
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.zip
+*.gem
+*.air
+*.part
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b7266f16f68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
+pkgname=peek-git
+pkgver=0.9.1.r186.g05f4355
+pkgrel=1
+pkgdesc="Simple animated GIF screen recorder with an easy to use interface (latest development release)"
+arch=('i686' 'x86_64')
+url="https://github.com/phw/peek"
+license=('GPL3')
+provides=('peek=${pkgver}')
+conflicts=('peek')
+depends=(gtk3 libkeybinder3 ffmpeg imagemagick)
+makedepends=(cmake vala gettext)
+optdepends=(
+ 'gst-plugins-good: WebM output under Gnome Shell'
+ 'gst-plugins-ugly: MP4 output under Gnome Shell'
+)
+source=(git+https://github.com/phw/peek.git)
+sha1sums=('SKIP')
+
+build() {
+ cd "${srcdir}/peek"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=ON \
+ -DGSETTINGS_COMPILE=OFF .
+ make
+}
+
+check() {
+ cd "${srcdir}/peek"
+ make test
+}
+
+package() {
+ cd "${srcdir}/peek"
+ make DESTDIR=${pkgdir} install
+}
+
+pkgver() {
+ cd "${srcdir}/peek"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}