summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudio Kozický2021-05-16 10:50:41 +0200
committerClaudio Kozický2021-05-16 10:50:41 +0200
commit49b52991bfa83892fcdcd1599a982d4dfcdf926f (patch)
treec3e0c154fa6f563a62cee127f7a345b9bc319ce6
parentf29ac07dc39dff9718111586b66f3fd883331862 (diff)
downloadaur-49b52991bfa83892fcdcd1599a982d4dfcdf926f.tar.gz
Update to 0.10.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--QPainterPath.patch12
-rw-r--r--boost-placeholders.patch264
-rw-r--r--deque.patch12
5 files changed, 16 insertions, 332 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe2bf283ce21..e9dea23a7c7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = peercoin
pkgdesc = A peer-to-peer network-based digital currency
- pkgver = 0.9.0
- pkgrel = 5
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://www.peercoin.net/
arch = x86_64
license = MIT
@@ -11,25 +11,16 @@ pkgbase = peercoin
depends = db
depends = libevent
depends = miniupnpc
- depends = openssl
- depends = protobuf
depends = qrencode
depends = qt5-base
depends = zeromq
- source = peercoin-0.9.0.tar.gz::https://github.com/peercoin/peercoin/archive/v0.9.0ppc.tar.gz
- source = boost-placeholders.patch
- source = deque.patch
- source = QPainterPath.patch
- b2sums = c6b50d5c004216582d487e86470789bf3d146e2c42f8562e759fa65d2c3be72a03fe75f5dd2270da14ceb7538e499ad62cfe363ad66a0fddfc69d4ff4eb64ffc
- b2sums = 94304cb1e6af66204b166ba875eee6e1fe590721ad1dd6521728f924695e6be69181bbe7dff09c1b7ae450f6a50d0bd9e3b99d78566250260cfbba4d978d284f
- b2sums = 980c8ab54178b254defeecb9f19ecbf9f5e7433d5206995adae1d432e448ac923334be46df644adc428057a8dec57a692636ab007b4b392ff3230bc1aec3de1a
- b2sums = 865befa6759a559b5764efc80ee626fe6ca7dc01b13d585a30f168c544d3e0d270cc3c8e3aec5fb8feaf2451ccf91eaaf9e88453538241e3b639e5160a7f737d
+ source = peercoin-0.10.0.tar.gz::https://github.com/peercoin/peercoin/archive/v0.10.0ppc.tar.gz
+ b2sums = 77a60c9df5c7a8070dc77a82119516488e317ee46ccc0886790fa54c80d8d7ef8cdd02542a5f36f41132cf2ffdf8c26b6f64114df601ea0083a12648eae2501c
pkgname = peercoin-cli
pkgdesc = A peer-to-peer network-based digital currency - RPC client
depends = boost-libs
depends = libevent
- depends = openssl
pkgname = peercoin-daemon
pkgdesc = A peer-to-peer network-based digital currency - daemon
@@ -37,7 +28,6 @@ pkgname = peercoin-daemon
depends = db
depends = libevent
depends = miniupnpc
- depends = openssl
depends = zeromq
backup = etc/peercoin/peercoin.conf
@@ -47,14 +37,11 @@ pkgname = peercoin-qt
depends = db
depends = libevent
depends = miniupnpc
- depends = protobuf
depends = qrencode
depends = qt5-base
- depends = openssl
depends = zeromq
pkgname = peercoin-tx
pkgdesc = A peer-to-peer network-based digital currency - transaction tool
depends = boost-libs
- depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 07ee7705a6cf..0696ed451e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,16 @@
pkgname=('peercoin-cli' 'peercoin-daemon' 'peercoin-qt' 'peercoin-tx')
pkgbase='peercoin'
-pkgver=0.9.0
-pkgrel=5
+pkgver=0.10.0
+pkgrel=1
pkgdesc="A peer-to-peer network-based digital currency"
arch=('x86_64')
url="https://www.peercoin.net/"
license=('MIT')
-depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'openssl' 'protobuf'
- 'qrencode' 'qt5-base' 'zeromq')
+depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'qrencode' 'qt5-base' 'zeromq')
makedepends=('boost' 'qt5-tools')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/peercoin/peercoin/archive/v${pkgver}ppc.tar.gz"
- 'boost-placeholders.patch'
- 'deque.patch'
- 'QPainterPath.patch')
-b2sums=('c6b50d5c004216582d487e86470789bf3d146e2c42f8562e759fa65d2c3be72a03fe75f5dd2270da14ceb7538e499ad62cfe363ad66a0fddfc69d4ff4eb64ffc'
- '94304cb1e6af66204b166ba875eee6e1fe590721ad1dd6521728f924695e6be69181bbe7dff09c1b7ae450f6a50d0bd9e3b99d78566250260cfbba4d978d284f'
- '980c8ab54178b254defeecb9f19ecbf9f5e7433d5206995adae1d432e448ac923334be46df644adc428057a8dec57a692636ab007b4b392ff3230bc1aec3de1a'
- '865befa6759a559b5764efc80ee626fe6ca7dc01b13d585a30f168c544d3e0d270cc3c8e3aec5fb8feaf2451ccf91eaaf9e88453538241e3b639e5160a7f737d')
-
-prepare() {
- cd "$pkgbase-${pkgver}ppc"
- patch --strip 1 --input "$srcdir/boost-placeholders.patch" # fix compilation error
- patch --strip 1 --input "$srcdir/deque.patch" # fix compilation error
- patch --strip 1 --input "$srcdir/QPainterPath.patch" # fix compilation error
-}
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/peercoin/peercoin/archive/v${pkgver}ppc.tar.gz")
+b2sums=('77a60c9df5c7a8070dc77a82119516488e317ee46ccc0886790fa54c80d8d7ef8cdd02542a5f36f41132cf2ffdf8c26b6f64114df601ea0083a12648eae2501c')
build() {
cd "$pkgbase-${pkgver}ppc"
@@ -42,7 +28,7 @@ check() {
package_peercoin-cli() {
pkgdesc="A peer-to-peer network-based digital currency - RPC client"
- depends=('boost-libs' 'libevent' 'openssl')
+ depends=('boost-libs' 'libevent')
cd "$pkgbase-${pkgver}ppc"
install -D --mode 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
@@ -60,7 +46,7 @@ package_peercoin-cli() {
package_peercoin-daemon() {
pkgdesc="A peer-to-peer network-based digital currency - daemon"
- depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'openssl' 'zeromq')
+ depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'zeromq')
optdepeneds=('tor')
backup=('etc/peercoin/peercoin.conf')
@@ -68,7 +54,7 @@ package_peercoin-daemon() {
install -D --mode 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
install -D --mode 644 \
- contrib/debian/examples/peercoin.conf \
+ share/examples/peercoin.conf \
"$pkgdir/etc/peercoin/peercoin.conf"
install -D --mode 644 \
contrib/peercoind.bash-completion \
@@ -83,7 +69,7 @@ package_peercoin-daemon() {
contrib/debian/manpages/peercoin.conf.5 \
"$pkgdir/usr/share/man/man5/peercoin.conf.5"
install -D --mode 644 \
- contrib/debian/manpages/peercoind.1 \
+ doc/man/peercoind.1 \
"$pkgdir/usr/share/man/man1/peercoind.1"
install -D --mode 755 \
src/peercoind \
@@ -92,8 +78,7 @@ package_peercoin-daemon() {
package_peercoin-qt() {
pkgdesc="A peer-to-peer network-based digital currency - Qt"
- depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'protobuf' 'qrencode'
- 'qt5-base' 'openssl' 'zeromq')
+ depends=('boost-libs' 'db' 'libevent' 'miniupnpc' 'qrencode' 'qt5-base' 'zeromq')
cd "$pkgbase-${pkgver}ppc"
install -D --mode 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
@@ -102,7 +87,7 @@ package_peercoin-qt() {
contrib/debian/peercoin-qt.desktop \
"$pkgdir/usr/share/applications/peercoin-qt.desktop"
install -D --mode 644 \
- contrib/debian/manpages/peercoin-qt.1 \
+ doc/man/peercoin-qt.1 \
"$pkgdir/usr/share/man/man1/peercoin-qt.1"
install -D --mode 644 \
share/pixmaps/peercoin128.png \
@@ -114,7 +99,7 @@ package_peercoin-qt() {
package_peercoin-tx() {
pkgdesc="A peer-to-peer network-based digital currency - transaction tool"
- depends=('boost-libs' 'openssl')
+ depends=('boost-libs')
cd "$pkgbase-${pkgver}ppc"
install -D --mode 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
diff --git a/QPainterPath.patch b/QPainterPath.patch
deleted file mode 100644
index fff16b71a87f..000000000000
--- a/QPainterPath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
-index f86979946..0021a2585 100644
---- a/src/qt/trafficgraphwidget.cpp
-+++ b/src/qt/trafficgraphwidget.cpp
-@@ -6,6 +6,7 @@
- #include <qt/clientmodel.h>
-
- #include <QPainter>
-+#include <QPainterPath>
- #include <QColor>
- #include <QTimer>
-
diff --git a/boost-placeholders.patch b/boost-placeholders.patch
deleted file mode 100644
index 2a51d788019a..000000000000
--- a/boost-placeholders.patch
+++ /dev/null
@@ -1,264 +0,0 @@
-diff --git a/src/qt/bitcoingui.cpp b/src/qt/bitcoingui.cpp
-index e322d5f02..4e60ef5cf 100644
---- a/src/qt/bitcoingui.cpp
-+++ b/src/qt/bitcoingui.cpp
-@@ -1258,15 +1258,15 @@ static bool ThreadSafeMessageBox(BitcoinGUI *gui, const std::string& message, co
- void BitcoinGUI::subscribeToCoreSignals()
- {
- // Connect signals to client
-- uiInterface.ThreadSafeMessageBox.connect(boost::bind(ThreadSafeMessageBox, this, _1, _2, _3));
-- uiInterface.ThreadSafeQuestion.connect(boost::bind(ThreadSafeMessageBox, this, _1, _3, _4));
-+ uiInterface.ThreadSafeMessageBox.connect(boost::bind(ThreadSafeMessageBox, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ uiInterface.ThreadSafeQuestion.connect(boost::bind(ThreadSafeMessageBox, this, boost::placeholders::_1, boost::placeholders::_3, boost::placeholders::_4));
- }
-
- void BitcoinGUI::unsubscribeFromCoreSignals()
- {
- // Disconnect signals from client
-- uiInterface.ThreadSafeMessageBox.disconnect(boost::bind(ThreadSafeMessageBox, this, _1, _2, _3));
-- uiInterface.ThreadSafeQuestion.disconnect(boost::bind(ThreadSafeMessageBox, this, _1, _3, _4));
-+ uiInterface.ThreadSafeMessageBox.disconnect(boost::bind(ThreadSafeMessageBox, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ uiInterface.ThreadSafeQuestion.disconnect(boost::bind(ThreadSafeMessageBox, this, boost::placeholders::_1, boost::placeholders::_3, boost::placeholders::_4));
- }
-
- void BitcoinGUI::toggleNetworkActive()
-diff --git a/src/qt/clientmodel.cpp b/src/qt/clientmodel.cpp
-index c12a474f4..5953c80fc 100644
---- a/src/qt/clientmodel.cpp
-+++ b/src/qt/clientmodel.cpp
-@@ -333,23 +333,23 @@ static void BlockTipChanged(ClientModel *clientmodel, bool initialSync, const CB
- void ClientModel::subscribeToCoreSignals()
- {
- // Connect signals to client
-- uiInterface.ShowProgress.connect(boost::bind(ShowProgress, this, _1, _2));
-- uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this, _1));
-- uiInterface.NotifyNetworkActiveChanged.connect(boost::bind(NotifyNetworkActiveChanged, this, _1));
-- uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, _1, _2));
-+ uiInterface.ShowProgress.connect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
-+ uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this, boost::placeholders::_1));
-+ uiInterface.NotifyNetworkActiveChanged.connect(boost::bind(NotifyNetworkActiveChanged, this, boost::placeholders::_1));
-+ uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1, boost::placeholders::_2));
- uiInterface.BannedListChanged.connect(boost::bind(BannedListChanged, this));
-- uiInterface.NotifyBlockTip.connect(boost::bind(BlockTipChanged, this, _1, _2, false));
-- uiInterface.NotifyHeaderTip.connect(boost::bind(BlockTipChanged, this, _1, _2, true));
-+ uiInterface.NotifyBlockTip.connect(boost::bind(BlockTipChanged, this, boost::placeholders::_1, boost::placeholders::_2, false));
-+ uiInterface.NotifyHeaderTip.connect(boost::bind(BlockTipChanged, this, boost::placeholders::_1, boost::placeholders::_2, true));
- }
-
- void ClientModel::unsubscribeFromCoreSignals()
- {
- // Disconnect signals from client
-- uiInterface.ShowProgress.disconnect(boost::bind(ShowProgress, this, _1, _2));
-- uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this, _1));
-- uiInterface.NotifyNetworkActiveChanged.disconnect(boost::bind(NotifyNetworkActiveChanged, this, _1));
-- uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, _1, _2));
-+ uiInterface.ShowProgress.disconnect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
-+ uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this, boost::placeholders::_1));
-+ uiInterface.NotifyNetworkActiveChanged.disconnect(boost::bind(NotifyNetworkActiveChanged, this, boost::placeholders::_1));
-+ uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1, boost::placeholders::_2));
- uiInterface.BannedListChanged.disconnect(boost::bind(BannedListChanged, this));
-- uiInterface.NotifyBlockTip.disconnect(boost::bind(BlockTipChanged, this, _1, _2, false));
-- uiInterface.NotifyHeaderTip.disconnect(boost::bind(BlockTipChanged, this, _1, _2, true));
-+ uiInterface.NotifyBlockTip.disconnect(boost::bind(BlockTipChanged, this, boost::placeholders::_1, boost::placeholders::_2, false));
-+ uiInterface.NotifyHeaderTip.disconnect(boost::bind(BlockTipChanged, this, boost::placeholders::_1, boost::placeholders::_2, true));
- }
-diff --git a/src/qt/mintingtablemodel.cpp b/src/qt/mintingtablemodel.cpp
-index a8afd26ac..6ec9c8ffb 100644
---- a/src/qt/mintingtablemodel.cpp
-+++ b/src/qt/mintingtablemodel.cpp
-@@ -286,12 +286,12 @@ MintingTableModel::MintingTableModel(CWallet* wallet, WalletModel *parent) :
- timer->start(MODEL_UPDATE_DELAY);
-
- connect(walletModel->getOptionsModel(), SIGNAL(displayUnitChanged(int)), this, SLOT(updateDisplayUnit()));
-- wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-+ wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
- }
-
- MintingTableModel::~MintingTableModel()
- {
-- wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-+ wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
- delete priv;
- }
-
-diff --git a/src/qt/splashscreen.cpp b/src/qt/splashscreen.cpp
-index e81edcb14..7f6c34b46 100644
---- a/src/qt/splashscreen.cpp
-+++ b/src/qt/splashscreen.cpp
-@@ -184,7 +184,7 @@ static void ShowProgress(SplashScreen *splash, const std::string &title, int nPr
- #ifdef ENABLE_WALLET
- void SplashScreen::ConnectWallet(CWallet* wallet)
- {
-- wallet->ShowProgress.connect(boost::bind(ShowProgress, this, _1, _2, false));
-+ wallet->ShowProgress.connect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2, false));
- connectedWallets.push_back(wallet);
- }
- #endif
-@@ -192,21 +192,21 @@ void SplashScreen::ConnectWallet(CWallet* wallet)
- void SplashScreen::subscribeToCoreSignals()
- {
- // Connect signals to client
-- uiInterface.InitMessage.connect(boost::bind(InitMessage, this, _1));
-- uiInterface.ShowProgress.connect(boost::bind(ShowProgress, this, _1, _2, _3));
-+ uiInterface.InitMessage.connect(boost::bind(InitMessage, this, boost::placeholders::_1));
-+ uiInterface.ShowProgress.connect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
- #ifdef ENABLE_WALLET
-- uiInterface.LoadWallet.connect(boost::bind(&SplashScreen::ConnectWallet, this, _1));
-+ uiInterface.LoadWallet.connect(boost::bind(&SplashScreen::ConnectWallet, this, boost::placeholders::_1));
- #endif
- }
-
- void SplashScreen::unsubscribeFromCoreSignals()
- {
- // Disconnect signals from client
-- uiInterface.InitMessage.disconnect(boost::bind(InitMessage, this, _1));
-- uiInterface.ShowProgress.disconnect(boost::bind(ShowProgress, this, _1, _2, _3));
-+ uiInterface.InitMessage.disconnect(boost::bind(InitMessage, this, boost::placeholders::_1));
-+ uiInterface.ShowProgress.disconnect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
- #ifdef ENABLE_WALLET
- for (CWallet* const & pwallet : connectedWallets) {
-- pwallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, _1, _2, false));
-+ pwallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2, false));
- }
- #endif
- }
-diff --git a/src/qt/transactiontablemodel.cpp b/src/qt/transactiontablemodel.cpp
-index e2bbc1ba7..e23f7b0ac 100644
---- a/src/qt/transactiontablemodel.cpp
-+++ b/src/qt/transactiontablemodel.cpp
-@@ -780,13 +780,13 @@ static void ShowProgress(TransactionTableModel *ttm, const std::string &title, i
- void TransactionTableModel::subscribeToCoreSignals()
- {
- // Connect signals to wallet
-- wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-- wallet->ShowProgress.connect(boost::bind(ShowProgress, this, _1, _2));
-+ wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ wallet->ShowProgress.connect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- void TransactionTableModel::unsubscribeFromCoreSignals()
- {
- // Disconnect signals from wallet
-- wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-- wallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, _1, _2));
-+ wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ wallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-diff --git a/src/qt/walletmodel.cpp b/src/qt/walletmodel.cpp
-index 398f36e7c..de51ed80a 100644
---- a/src/qt/walletmodel.cpp
-+++ b/src/qt/walletmodel.cpp
-@@ -508,21 +508,21 @@ static void NotifyWatchonlyChanged(WalletModel *walletmodel, bool fHaveWatchonly
- void WalletModel::subscribeToCoreSignals()
- {
- // Connect signals to wallet
-- wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
-- wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5, _6));
-- wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-- wallet->ShowProgress.connect(boost::bind(ShowProgress, this, _1, _2));
-- wallet->NotifyWatchonlyChanged.connect(boost::bind(NotifyWatchonlyChanged, this, _1));
-+ wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
-+ wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5, boost::placeholders::_6));
-+ wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ wallet->ShowProgress.connect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
-+ wallet->NotifyWatchonlyChanged.connect(boost::bind(NotifyWatchonlyChanged, this, boost::placeholders::_1));
- }
-
- void WalletModel::unsubscribeFromCoreSignals()
- {
- // Disconnect signals from wallet
-- wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
-- wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5, _6));
-- wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
-- wallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, _1, _2));
-- wallet->NotifyWatchonlyChanged.disconnect(boost::bind(NotifyWatchonlyChanged, this, _1));
-+ wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
-+ wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5, boost::placeholders::_6));
-+ wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ wallet->ShowProgress.disconnect(boost::bind(ShowProgress, this, boost::placeholders::_1, boost::placeholders::_2));
-+ wallet->NotifyWatchonlyChanged.disconnect(boost::bind(NotifyWatchonlyChanged, this, boost::placeholders::_1));
- }
-
- // WalletModel::UnlockContext implementation
-diff --git a/src/validation.cpp b/src/validation.cpp
-index f066ad353..7b542af89 100644
---- a/src/validation.cpp
-+++ b/src/validation.cpp
-@@ -2112,11 +2112,11 @@ private:
-
- public:
- explicit ConnectTrace(CTxMemPool &_pool) : blocksConnected(1), pool(_pool) {
-- pool.NotifyEntryRemoved.connect(boost::bind(&ConnectTrace::NotifyEntryRemoved, this, _1, _2));
-+ pool.NotifyEntryRemoved.connect(boost::bind(&ConnectTrace::NotifyEntryRemoved, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- ~ConnectTrace() {
-- pool.NotifyEntryRemoved.disconnect(boost::bind(&ConnectTrace::NotifyEntryRemoved, this, _1, _2));
-+ pool.NotifyEntryRemoved.disconnect(boost::bind(&ConnectTrace::NotifyEntryRemoved, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- void BlockConnected(CBlockIndex* pindex, std::shared_ptr<const CBlock> pblock) {
-diff --git a/src/validationinterface.cpp b/src/validationinterface.cpp
-index 90513bc6c..e76bb3c0d 100644
---- a/src/validationinterface.cpp
-+++ b/src/validationinterface.cpp
-@@ -61,11 +61,11 @@ size_t CMainSignals::CallbacksPending() {
- }
-
- void CMainSignals::RegisterWithMempoolSignals(CTxMemPool& pool) {
-- pool.NotifyEntryRemoved.connect(boost::bind(&CMainSignals::MempoolEntryRemoved, this, _1, _2));
-+ pool.NotifyEntryRemoved.connect(boost::bind(&CMainSignals::MempoolEntryRemoved, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- void CMainSignals::UnregisterWithMempoolSignals(CTxMemPool& pool) {
-- pool.NotifyEntryRemoved.disconnect(boost::bind(&CMainSignals::MempoolEntryRemoved, this, _1, _2));
-+ pool.NotifyEntryRemoved.disconnect(boost::bind(&CMainSignals::MempoolEntryRemoved, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- CMainSignals& GetMainSignals()
-@@ -74,27 +74,27 @@ CMainSignals& GetMainSignals()
- }
-
- void RegisterValidationInterface(CValidationInterface* pwalletIn) {
-- g_signals.m_internals->UpdatedBlockTip.connect(boost::bind(&CValidationInterface::UpdatedBlockTip, pwalletIn, _1, _2, _3));
-- g_signals.m_internals->TransactionAddedToMempool.connect(boost::bind(&CValidationInterface::TransactionAddedToMempool, pwalletIn, _1));
-- g_signals.m_internals->BlockConnected.connect(boost::bind(&CValidationInterface::BlockConnected, pwalletIn, _1, _2, _3));
-- g_signals.m_internals->BlockDisconnected.connect(boost::bind(&CValidationInterface::BlockDisconnected, pwalletIn, _1));
-- g_signals.m_internals->TransactionRemovedFromMempool.connect(boost::bind(&CValidationInterface::TransactionRemovedFromMempool, pwalletIn, _1));
-- g_signals.m_internals->SetBestChain.connect(boost::bind(&CValidationInterface::SetBestChain, pwalletIn, _1));
-- g_signals.m_internals->Broadcast.connect(boost::bind(&CValidationInterface::ResendWalletTransactions, pwalletIn, _1, _2));
-- g_signals.m_internals->BlockChecked.connect(boost::bind(&CValidationInterface::BlockChecked, pwalletIn, _1, _2));
-- g_signals.m_internals->NewPoWValidBlock.connect(boost::bind(&CValidationInterface::NewPoWValidBlock, pwalletIn, _1, _2));
-+ g_signals.m_internals->UpdatedBlockTip.connect(boost::bind(&CValidationInterface::UpdatedBlockTip, pwalletIn, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ g_signals.m_internals->TransactionAddedToMempool.connect(boost::bind(&CValidationInterface::TransactionAddedToMempool, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->BlockConnected.connect(boost::bind(&CValidationInterface::BlockConnected, pwalletIn, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ g_signals.m_internals->BlockDisconnected.connect(boost::bind(&CValidationInterface::BlockDisconnected, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->TransactionRemovedFromMempool.connect(boost::bind(&CValidationInterface::TransactionRemovedFromMempool, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->SetBestChain.connect(boost::bind(&CValidationInterface::SetBestChain, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->Broadcast.connect(boost::bind(&CValidationInterface::ResendWalletTransactions, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
-+ g_signals.m_internals->BlockChecked.connect(boost::bind(&CValidationInterface::BlockChecked, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
-+ g_signals.m_internals->NewPoWValidBlock.connect(boost::bind(&CValidationInterface::NewPoWValidBlock, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- void UnregisterValidationInterface(CValidationInterface* pwalletIn) {
-- g_signals.m_internals->BlockChecked.disconnect(boost::bind(&CValidationInterface::BlockChecked, pwalletIn, _1, _2));
-- g_signals.m_internals->Broadcast.disconnect(boost::bind(&CValidationInterface::ResendWalletTransactions, pwalletIn, _1, _2));
-- g_signals.m_internals->SetBestChain.disconnect(boost::bind(&CValidationInterface::SetBestChain, pwalletIn, _1));
-- g_signals.m_internals->TransactionAddedToMempool.disconnect(boost::bind(&CValidationInterface::TransactionAddedToMempool, pwalletIn, _1));
-- g_signals.m_internals->BlockConnected.disconnect(boost::bind(&CValidationInterface::BlockConnected, pwalletIn, _1, _2, _3));
-- g_signals.m_internals->BlockDisconnected.disconnect(boost::bind(&CValidationInterface::BlockDisconnected, pwalletIn, _1));
-- g_signals.m_internals->TransactionRemovedFromMempool.disconnect(boost::bind(&CValidationInterface::TransactionRemovedFromMempool, pwalletIn, _1));
-- g_signals.m_internals->UpdatedBlockTip.disconnect(boost::bind(&CValidationInterface::UpdatedBlockTip, pwalletIn, _1, _2, _3));
-- g_signals.m_internals->NewPoWValidBlock.disconnect(boost::bind(&CValidationInterface::NewPoWValidBlock, pwalletIn, _1, _2));
-+ g_signals.m_internals->BlockChecked.disconnect(boost::bind(&CValidationInterface::BlockChecked, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
-+ g_signals.m_internals->Broadcast.disconnect(boost::bind(&CValidationInterface::ResendWalletTransactions, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
-+ g_signals.m_internals->SetBestChain.disconnect(boost::bind(&CValidationInterface::SetBestChain, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->TransactionAddedToMempool.disconnect(boost::bind(&CValidationInterface::TransactionAddedToMempool, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->BlockConnected.disconnect(boost::bind(&CValidationInterface::BlockConnected, pwalletIn, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ g_signals.m_internals->BlockDisconnected.disconnect(boost::bind(&CValidationInterface::BlockDisconnected, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->TransactionRemovedFromMempool.disconnect(boost::bind(&CValidationInterface::TransactionRemovedFromMempool, pwalletIn, boost::placeholders::_1));
-+ g_signals.m_internals->UpdatedBlockTip.disconnect(boost::bind(&CValidationInterface::UpdatedBlockTip, pwalletIn, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
-+ g_signals.m_internals->NewPoWValidBlock.disconnect(boost::bind(&CValidationInterface::NewPoWValidBlock, pwalletIn, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- void UnregisterAllValidationInterfaces() {
diff --git a/deque.patch b/deque.patch
deleted file mode 100644
index 018c934515f9..000000000000
--- a/deque.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/httpserver.cpp b/src/httpserver.cpp
-index d36c74b01..2d835387f 100644
---- a/src/httpserver.cpp
-+++ b/src/httpserver.cpp
-@@ -13,6 +13,7 @@
- #include <sync.h>
- #include <ui_interface.h>
-
-+#include <deque>
- #include <memory>
- #include <stdio.h>
- #include <stdlib.h>