summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcimer2018-10-28 19:50:25 +0100
committercimer2018-10-28 19:50:25 +0100
commit666cfa9569c1cc6a23686d32e9620c9fe7979a9f (patch)
tree47ec731696cc8a7a68615cb0ff80c38823f66f58
parent8002c86a277344ff906e5cf8ce0e80addb5b0fa6 (diff)
downloadaur-666cfa9569c1cc6a23686d32e9620c9fe7979a9f.tar.gz
update to v0.6.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--boost.patch44
3 files changed, 60 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfe7e8d2dd35..65f894e1e564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = peercoin
pkgdesc = Official Peercoin wallet.
- pkgver = 0.6.2
- pkgrel = 3
+ pkgver = 0.6.4
+ pkgrel = 1
url = peercoin.net
arch = x86_64
arch = i686
@@ -22,12 +22,14 @@ pkgbase = peercoin
replaces = ppcoin-daemon
replaces = ppcoin-qt
replaces = ppcoind
- source = https://github.com/peercoin/peercoin/archive/v0.6.2ppc.tar.gz
+ source = https://github.com/peercoin/peercoin/archive/v0.6.4ppc.tar.gz
source = peercoin-qt@.service
source = peercoin-qt-tor@.service
- sha256sums = f6ce0647c9f3b4b4c28c5b77955c9ae4808a8c7f5e55a99f1337317a29a0bc1b
+ source = boost.patch
+ sha256sums = 7ff245911146a146877da44d0e0828dd9ef50b97feda34a218ed4e936dc8733f
sha256sums = bc898697baab589b87b0b78edd5aed35a3b800fe039afc03637b4895cfd28f32
sha256sums = 3f71859675561dd35c4527d96651b07996968e318dfbf26e8ce959f61a0d682f
+ sha256sums = fbfe8ff248971cba5e676581f6f2dde5e870962014920b6c7f0a2ea88d12a967
pkgname = peercoin-qt
pkgdesc = Official implementation of Peercoin, the sustainable and secure cryptocurrency alternative to Bitcoin - QT wallet.
diff --git a/PKGBUILD b/PKGBUILD
index 99d45d243567..2e11e09aecd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=('peercoin-qt' 'peercoind')
pkgbase=peercoin
_gitname=peercoin
-pkgver=0.6.2
-pkgrel=4
+pkgver=0.6.4
+pkgrel=1
pkgdesc="Official Peercoin wallet."
makedepends=('gcc' 'make' 'boost' 'miniupnpc' 'openssl' 'qt5-base' 'qt5-tools')
depends=('boost-libs' 'openssl' 'miniupnpc' 'qt5-base')
@@ -16,13 +16,16 @@ license=('MIT')
source=(https://github.com/peercoin/peercoin/archive/v${pkgver}ppc.tar.gz
peercoin-qt@.service
peercoin-qt-tor@.service
+ boost.patch
)
-sha256sums=('d64a8fdcd874d2e211f5dd3002e187769b3ec656f985f538ea0510f1b58ac2b6'
+sha256sums=('7ff245911146a146877da44d0e0828dd9ef50b97feda34a218ed4e936dc8733f'
'bc898697baab589b87b0b78edd5aed35a3b800fe039afc03637b4895cfd28f32'
- '3f71859675561dd35c4527d96651b07996968e318dfbf26e8ce959f61a0d682f')
+ '3f71859675561dd35c4527d96651b07996968e318dfbf26e8ce959f61a0d682f'
+ 'fbfe8ff248971cba5e676581f6f2dde5e870962014920b6c7f0a2ea88d12a967')
prepare() {
cd "$srcdir/${_gitname}-${pkgver}ppc"
+ patch -Np1 -i "${startdir}/boost.patch"
./autogen.sh
}
@@ -71,8 +74,8 @@ package_peercoind() {
cd "$srcdir/${_gitname}-${pkgver}ppc"
install -Dm755 "src/peercoind" "$pkgdir/usr/bin/$pkgname"
- install -Dm755 "src/peercoin-cli" "$pkgdir/usr/bin/peercoin-cli"
- install -Dm644 "contrib/systemd/${_gitname}d-tor@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d-tor@.service"
- install -Dm644 "contrib/systemd/${_gitname}d@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d@.service"
+ install -Dm755 "src/peercoin-cli" "$pkgdir/usr/bin/peercoin-cli"
+ install -Dm644 "contrib/systemd/${_gitname}d-tor@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d-tor@.service"
+ install -Dm644 "contrib/systemd/${_gitname}d@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d@.service"
}
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..ad58e32a632f
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,44 @@
+diff --git a/bitcoin-qt.pro b/bitcoin-qt.pro
+index a90ee449f029..18f2612dfd72 100644
+--- a/bitcoin-qt.pro
++++ b/bitcoin-qt.pro
+@@ -8,6 +8,7 @@ greaterThan(QT_MAJOR_VERSION, 4):QT+=widgets
+ DEFINES += QT_GUI BOOST_THREAD_USE_LIB BOOST_SPIRIT_THREADSAFE HAVE_WORKING_BOOST_SLEEP_FOR
+ CONFIG += no_include_pwd
+ CONFIG += thread
++CONFIG += c++11
+
+ # for boost 1.37, add -mt to the boost libraries
+ # use: qmake BOOST_LIB_SUFFIX=-mt
+diff --git a/src/util.h b/src/util.h
+index 3599d0e66fe6..cf3dc0eadb12 100644
+--- a/src/util.h
++++ b/src/util.h
+@@ -24,6 +24,8 @@ typedef int pid_t; /* define for Windows compatibility */
+ #include <utility>
+ #include <vector>
+ #include <string>
++#include <chrono>
++#include <thread>
+
+ #include <boost/version.hpp>
+ #include <boost/thread.hpp>
+@@ -109,17 +111,7 @@ T* alignup(T* p)
+
+ inline void MilliSleep(int64 n)
+ {
+-// Boost's sleep_for was uninterruptable when backed by nanosleep from 1.50
+-// until fixed in 1.52. Use the deprecated sleep method for the broken case.
+-// See: https://svn.boost.org/trac/boost/ticket/7238
+-#if defined(HAVE_WORKING_BOOST_SLEEP_FOR)
+- boost::this_thread::sleep_for(boost::chrono::milliseconds(n));
+-#elif defined(HAVE_WORKING_BOOST_SLEEP)
+- boost::this_thread::sleep(boost::posix_time::milliseconds(n));
+-#else
+- //should never get here
+-#error missing boost sleep implementation
+-#endif
++ std::this_thread::sleep_for(std::chrono::milliseconds(n));
+ }
+
+ #ifndef THROW_WITH_STACKTRACE