summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcimer2017-10-30 14:38:04 +0100
committercimer2017-10-30 14:38:04 +0100
commite0a227c32098860fccfdf726689406235ad28133 (patch)
tree3386d32c84d25f83fe171bbac6719fdc466f1567
parentb10dbee3b5d030c7420a3d5a196b5beae62ec027 (diff)
downloadaur-e0a227c32098860fccfdf726689406235ad28133.tar.gz
split .install files and other minor fixes.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--peercoin-qt.install18
-rw-r--r--peercoind.install18
4 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 893a13ade437..e1f19b0bc6ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = peercoin
pkgdesc = Peercoin wallet client.
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 3
url = peercoin.net
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d9238f54ba05..63503145eebc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=('peercoin-qt' 'peercoind')
pkgbase=peercoin
_gitname=peercoin
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="Official Peercoin wallet."
makedepends=('gcc' 'make' 'boost' 'miniupnpc' 'openssl' 'qt5-base' 'qt5-tools')
depends=('boost-libs' 'openssl' 'miniupnpc' 'qt5-base')
@@ -29,7 +29,7 @@ build() {
cd "$srcdir/${_gitname}-${pkgver}ppc"
## make qt gui
- qmake-qt5 USE_QRCODE=1 USE_UPNP=1 \
+ qmake-qt5 USE_QRCODE=1 USE_UPNP=1 USE_DBUS=1 \
QMAKE_CFLAGS="${CFLAGS}"\
QMAKE_CXXFLAGS="${CXXFLAGS} -pie"
make
@@ -50,7 +50,7 @@ package_peercoin-qt() {
makedepends=('gcc' 'make' 'qt5-base' 'boost' 'gcc' 'make' 'qrencode' 'openssl' 'miniupnpc' 'qt5-tools')
depends=('qt5-base' 'miniupnpc' 'boost-libs' 'qrencode' 'miniupnpc')
optdepeds=('systemd' 'tor')
- install=peercoin.install
+ install=peercoin-qt.install
install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 $pkgname@.service "${pkgdir}/usr/lib/systemd/system/$pkgname@.service"
@@ -69,7 +69,7 @@ package_peercoind() {
depends=('gcc' 'make' 'boost-libs' 'miniupnpc')
optdepeneds=('systemd' 'tor')
pkgdesc="Official implementation of Peercoin, the sustainable and secure cryptocurrency alternative to Bitcoin - daemon."
- install=peercoin.install
+ install=peercoind.install
install -Dm644 $pkgname@.service "$pkgdir/usr/lib/systemd/system/$pkgname@.service"
install -Dm644 $pkgname-tor@.service "$pkgdir/usr/lib/systemd/system/$pkgname-tor@.service"
diff --git a/peercoin-qt.install b/peercoin-qt.install
new file mode 100644
index 000000000000..8361a4c3ab2f
--- /dev/null
+++ b/peercoin-qt.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+ systemctl daemon-reload
+ # ln to keep compatibility
+ ln -s /usr/bin/peercoin-qt /usr/bin/ppcoin-qt
+
+ echo ""
+ echo "If you are having troubles with blockchain download, just backup wallet.dat, remove .ppcoin directory and start over."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+ rm /usr/bin/ppcoin-qt
+}
diff --git a/peercoind.install b/peercoind.install
new file mode 100644
index 000000000000..73564fecf543
--- /dev/null
+++ b/peercoind.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+ systemctl daemon-reload
+ # ln to old name to keep compatibility
+ ln -s /usr/bin/peercoind /usr/bin/ppcoind
+
+ echo ""
+ echo "If you are having troubles with blockchain download, just backup wallet.dat, remove .ppcoin directory and start over."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+ rm /usr/bin/ppcoind
+}