summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcimer2017-11-05 13:24:59 +0100
committercimer2017-11-05 13:24:59 +0100
commitf9cf404eae19376c663471f4e7296aa9cc93bf84 (patch)
tree703af5df533bc2cf0a224837a4b95e6df5a40059
downloadaur-f9cf404eae19376c663471f4e7296aa9cc93bf84.tar.gz
initial commit.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD49
-rw-r--r--peercoind-git.install18
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1031c19c81cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = peercoin
+ pkgdesc = Peercoin deamon - master branch.
+ pkgver = v0.6.1.rc1.r0.g162f0694
+ pkgrel = 1
+ url = peercoin.net
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = gcc
+ makedepends = make
+ makedepends = boost
+ makedepends = miniupnpc
+ makedepends = openssl
+ depends = boost-libs
+ depends = openssl
+ depends = miniupnpc
+ replaces = peercoind
+ source = git+https://github.com/peercoin/peercoin.git#branch=master
+ sha256sums = SKIP
+
+pkgname = peercoind-git
+ pkgdesc = Official implementation of Peercoin, the sustainable and secure cryptocurrency alternative to Bitcoin - daemon.
+ install = peercoind-git.install
+ depends = gcc
+ depends = make
+ depends = boost-libs
+ depends = miniupnpc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c37488ec3647
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+## Maintainer: peerchemist <peerchemist@protonmail.ch>
+
+pkgname=('peercoind-git')
+pkgbase=peercoin
+_gitname=peercoin
+pkgver=v0.6.1.rc1.r0.g162f0694
+pkgrel=1
+pkgdesc="Peercoin deamon - master branch."
+makedepends=('gcc' 'make' 'boost' 'miniupnpc' 'openssl')
+depends=('boost-libs' 'openssl' 'miniupnpc')
+replaces=("peercoind")
+arch=('x86_64' 'i686')
+url='peercoin.net'
+license=('MIT')
+source=(git+https://github.com/${_gitname}/${_gitname}.git#branch=master)
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/${_gitname}"
+
+ ## make peercoind
+ make -f makefile.unix USE_UPNP=1 -e PIE=1 -C src
+}
+
+check() {
+ cd "$srcdir/${_gitname}"
+
+ make -f makefile.unix test_${_gitname} -C src
+}
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package_peercoind-git() {
+
+ makedepends=('boost' 'gcc' 'make' 'openssl' 'miniupnpc')
+ depends=('gcc' 'make' 'boost-libs' 'miniupnpc')
+ optdepeneds=('systemd' 'tor')
+ pkgdesc="Official implementation of Peercoin, the sustainable and secure cryptocurrency alternative to Bitcoin - daemon."
+ install=peercoind-git.install
+
+ cd "$srcdir/${_gitname}"
+ install -Dm755 "src/peercoind" "$pkgdir/usr/bin/peercoind"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/peercoin/COPYING"
+ install -Dm644 "contrib/systemd/${_gitname}d-tor@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d-tor@.service"
+ install -Dm644 "contrib/systemd/${_gitname}d@.service" "$pkgdir/usr/lib/systemd/system/${_gitname}d@.service"
+}
diff --git a/peercoind-git.install b/peercoind-git.install
new file mode 100644
index 000000000000..73564fecf543
--- /dev/null
+++ b/peercoind-git.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+ systemctl daemon-reload
+ # ln to old name to keep compatibility
+ ln -s /usr/bin/peercoind /usr/bin/ppcoind
+
+ echo ""
+ echo "If you are having troubles with blockchain download, just backup wallet.dat, remove .ppcoin directory and start over."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+ rm /usr/bin/ppcoind
+}