summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Martin Moro2015-11-18 02:23:56 +0100
committerSamuel Martin Moro2015-11-18 02:23:56 +0100
commit8055adead0b3a04f1ed53b3d458dc2bc91c0a1b5 (patch)
treec1235f630c591bc62d049f07d18e29fe4ff1c0ce
downloadaur-8055adead0b3a04f1ed53b3d458dc2bc91c0a1b5.tar.gz
initial commit / packaging Peerio for ArchLinux
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD23
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a87d3d7d325
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = peerio-client
+ pkgdesc = Peerio Client
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://peerio.com
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = fakeroot
+ makedepends = make
+ makedepends = npm
+ makedepends = python-pip
+ makedepends = sudo
+ depends = alsa-lib
+ depends = glibc
+ depends = cairo
+ depends = libdbus
+ depends = fontconfig
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = gtk3
+ depends = libnotify
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+ options = !strip
+ source = http://linux.peerio.com/sources/peerio-client-1.2.0.tar.gz
+ md5sums = 1689a08b2ea368fbc376ca2ba6d41f91
+
+pkgname = peerio-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8831af094622
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Samuel Martin Moro <samuel@peerio.com>
+pkgname=peerio-client
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Peerio Client"
+arch=('i686' 'x86_64')
+url='https://peerio.com'
+license=('GPL3')
+depends=('alsa-lib' 'glibc' 'cairo' 'libdbus' 'fontconfig' 'gconf' 'gdk-pixbuf2' 'gtk3' 'libnotify' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxtst' 'nspr' 'nss' 'pango')
+makedepends=('fakeroot' 'make' 'npm' 'python-pip' 'sudo')
+options=('!strip')
+#source=('http://linux.peerio.com/sources/${pkgname}-${pkgver}.tar.gz')
+source=('http://linux.peerio.com/sources/peerio-client-1.2.0.tar.gz')
+md5sums=('1689a08b2ea368fbc376ca2ba6d41f91')
+build() {
+ cd "${srcdir}/${pkgname}"
+ sed -i '/^[ \t]*winIco: /d' gulpfile.js
+ make client
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make install PREFIX="${pkgdir}/usr/share" BINPREFIX="${pkgdir}/usr"
+}