summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorslubman2015-10-06 17:17:49 +0200
committerslubman2015-10-06 17:17:49 +0200
commitb4914445eb923d4d59f22012c5782a921ee41e94 (patch)
tree905b9c237f95e361e5a4be8c49f2489398d749ed
parente1d406e3d74a49dc926a729276b06c93d158e502 (diff)
downloadaur-b4914445eb923d4d59f22012c5782a921ee41e94.tar.gz
Add db4.8 dependency
Using the system db package the database can’t be opened by the GUI and then the daemon. Using db4.8 the two programs can use the same database files.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cef8d7370b8..c97885264a5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = peerunity
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 3
url = http://www.peercoin.net/download-peerunity
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = peerunity
depends = boost-libs
depends = openssl
depends = miniupnpc
+ depends = db4.8
source = https://github.com/peerunity/peerunity/archive/v0.1.1.tar.gz
source = upnp-1.9.patch
source = peerunityd@.service
@@ -29,6 +30,7 @@ pkgname = peerunity-daemon
depends = boost-libs
depends = openssl
depends = miniupnpc
+ depends = db4.8
pkgname = peerunity-qt
pkgdesc = Comunity client for Peercoin peer-to-peer network based digital currency (Qt)
@@ -37,4 +39,5 @@ pkgname = peerunity-qt
depends = qt4
depends = qrencode
depends = miniupnpc
+ depends = db4.8
diff --git a/PKGBUILD b/PKGBUILD
index 34860dc1ffa2..edf9a3f84272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('peerunity-daemon' 'peerunity-qt')
pkgbase=peerunity
pkgver=0.1.1
-pkgrel=1
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.peercoin.net/download-peerunity"
makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc' 'protobuf')
@@ -19,7 +19,7 @@ sha256sums=('416ad4c36551b62e2048bcd6844004444ea52b2640c8c7c88bcbd6c0829c5499'
'cfc0b8accef8dee3d6559cdb880e13f4ef381119f4150d15cc3f74903da80f35'
'250aa80695bbb95228286850856d1f1bac9336c98e884cba0b148c9b837d196c'
'2d089702a9f02db640f7ae0f48b7b61f7de6ecddc3804f80484520b6c461a9b1')
-depends=('boost-libs' 'openssl' 'miniupnpc')
+depends=('boost-libs' 'openssl' 'miniupnpc' 'db4.8')
prepare() {
cd "$srcdir/Peerunity-$pkgver"
@@ -27,16 +27,19 @@ prepare() {
}
build() {
+ cd "$srcdir/Peerunity-$pkgver/src"
+ CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
+ BDB_INCLUDE_PATH="/usr/include/db4.8"
+ BDB_LIB_SUFFIX="-4.8"
+ make -f makefile.unix USE_UPNP=1 CXXFLAGS="$CXXFLAGS" BDB_INCLUDE_PATH="$BDB_INCLUDE_PATH" BDB_LIB_SUFFIX="$BDB_LIB_SUFFIX"
+
cd "$srcdir/Peerunity-$pkgver"
- qmake-qt4 "USE_UPNP=1" "USE_QRCODE=1"
+ qmake-qt4 "USE_UPNP=1" "USE_QRCODE=1" BDB_INCLUDE_PATH="$BDB_INCLUDE_PATH" BDB_LIB_SUFFIX="$BDB_LIB_SUFFIX" peerunity.pro
make
-
- cd "$srcdir/Peerunity-$pkgver/src"
- make -f makefile.unix USE_UPNP=1
}
package_peerunity-daemon() {
- depends=('boost-libs' 'openssl' 'miniupnpc')
+ depends=('boost-libs' 'openssl' 'miniupnpc' 'db4.8')
pkgdesc="Community client for Peercoin peer-to-peer network based digital currency (daemon)"
install -Dm644 peerunityd@.service "$pkgdir/usr/lib/systemd/system/peerunity@.service"
@@ -49,7 +52,7 @@ package_peerunity-daemon() {
}
package_peerunity-qt() {
- depends=('boost-libs' 'qt4' 'qrencode' 'miniupnpc')
+ depends=('boost-libs' 'qt4' 'qrencode' 'miniupnpc' 'db4.8')
install=peerunity-qt.install
pkgdesc="Comunity client for Peercoin peer-to-peer network based digital currency (Qt)"