summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Kaderli2022-12-08 19:39:43 +0100
committerSeverin Kaderli2022-12-08 19:39:43 +0100
commite1528b41c79fe74b1929f8c6efef6be14b29c7db (patch)
treeda40c76594ac24985df1a640ae0ec8ff4017cadd
parent227f54620cc1758ce90c4e68537d4dec000f11d4 (diff)
downloadaur-e1528b41c79fe74b1929f8c6efef6be14b29c7db.tar.gz
Fix submodules and add missing dependencies for video playback
Signed-off-by: Severin Kaderli <severin@kaderli.dev>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a596470aad5e..a2f161fcf2cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,8 @@ pkgbase = pegasus-frontend-git
depends = qt5-svg
depends = qt5-tools
depends = sdl2
+ depends = gst-libav
+ depends = gst-plugin-good
optdepends = polkit
provides = pegasus-frontend
conflicts = pegasus-frontend
@@ -29,4 +31,3 @@ pkgbase = pegasus-frontend-git
md5sums = SKIP
pkgname = pegasus-frontend-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 68ffaf073a3b..f8cecf95bcab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Severin Kaderli <severin.kaderli@gmail.com>
_pkgname=pegasus-frontend
pkgname=${_pkgname}-git
-pkgver=alpha14.r36.g49dd98b3
+pkgver=alpha16.r44.g8119fcec
pkgrel=1
pkgdesc="A cross platform, customizable graphical frontend for launching emulators and managing your game collection."
arch=('i686' 'x86_64')
@@ -20,6 +20,8 @@ depends=(
'qt5-svg'
'qt5-tools'
'sdl2'
+ 'gst-libav'
+ 'gst-plugins-good'
)
optdepends=(
'polkit'
@@ -50,7 +52,7 @@ prepare() {
git config submodule.lang.url "${srcdir}/pegasus-frontend-translations"
git config submodule.src/themes/pegasus-theme-grid.url "${srcdir}/pegasus-theme-grid"
git config submodule.thirdparty/SortFilterProxyModel.url "${srcdir}/SortFilterProxyModel"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {