summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:48:52 +0300
committervlad2015-07-08 15:48:52 +0300
commit0a8c4b1dfa36e87db07c46859b7de2ac684f6b59 (patch)
tree71a0a1faca15c563724f92161c2660aad7acee47
downloadaur-0a8c4b1dfa36e87db07c46859b7de2ac684f6b59.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--pencil.install7
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fea0b336fa2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pencil
+ pkgdesc = Sketching and GUI prototyping/wireframing tool
+ pkgver = 2.0.11
+ pkgrel = 1
+ url = http://github.com/prikhi/pencil
+ install = pencil.install
+ arch = any
+ license = GPL2
+ depends = xulrunner
+ optdepends = pencil-android-lollipop-stencils-git: Android UI
+ optdepends = pencil-material-icons-git: Material Design Icons
+ source = https://github.com/prikhi/pencil/releases/download/v2.0.11/Pencil-2.0.11-linux-pkg.tar.gz
+ sha256sums = a35d1353de6665cbd4a5bd821dcdf7439f2a3c1fcbccee0f01ec8dd1bb67c4f3
+
+pkgname = pencil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e1ff8326343
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Pavan Rikhi <pavan.rikhi@gmail.com>
+pkgname=pencil
+pkgver=2.0.11
+pkgrel=1
+pkgdesc="Sketching and GUI prototyping/wireframing tool"
+arch=('any')
+license=('GPL2')
+url="http://github.com/prikhi/pencil"
+install='pencil.install'
+
+source=("https://github.com/prikhi/pencil/releases/download/v$pkgver/Pencil-$pkgver-linux-pkg.tar.gz")
+sha256sums=('a35d1353de6665cbd4a5bd821dcdf7439f2a3c1fcbccee0f01ec8dd1bb67c4f3')
+depends=('xulrunner')
+optdepends=('pencil-android-lollipop-stencils-git: Android UI'
+ 'pencil-material-icons-git: Material Design Icons')
+
+package() {
+ cp -dr "$srcdir/evolus-pencil/usr" "$pkgdir"
+ # fix permissions of directories
+ chmod -R a+rX "$pkgdir"/*
+}
diff --git a/pencil.install b/pencil.install
new file mode 100644
index 000000000000..bcb3e47864e1
--- /dev/null
+++ b/pencil.install
@@ -0,0 +1,7 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ post_install $1
+}