summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-11-30 18:47:44 +0100
committerJakob Gahde2017-11-30 18:47:44 +0100
commite51642bf5bf7b163625b2b0520e7fda02e057f74 (patch)
tree2d23c3e24fe6997e42b8e62226a4f6a8ef6fe745
downloadaur-e51642bf5bf7b163625b2b0520e7fda02e057f74.tar.gz
pencil2d 0.6.0-1: New package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60c6a8a50482
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Nov 30 17:47:23 UTC 2017
+pkgbase = pencil2d
+ pkgdesc = An easy, intuitive tool to make 2D hand-drawn animations
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://pencil2d.org/
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-xmlpatterns
+ depends = hicolor-icon-theme
+ depends = ffmpeg
+ source = https://github.com/pencil2d/pencil/archive/0.6.0.tar.gz
+ md5sums = 46ec6cb485b45ede9bd6a9728c9fc1a5
+
+pkgname = pencil2d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d262cc07100
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=pencil2d
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="An easy, intuitive tool to make 2D hand-drawn animations"
+arch=('x86_64' 'i686')
+url="https://pencil2d.org/"
+license=('GPL2')
+depends=('qt5-multimedia' 'qt5-svg' 'qt5-xmlpatterns' 'hicolor-icon-theme' 'ffmpeg')
+source=("https://github.com/pencil2d/pencil/archive/${pkgver}.tar.gz")
+md5sums=('46ec6cb485b45ede9bd6a9728c9fc1a5')
+
+build() {
+ cd "${srcdir}/pencil-${pkgver}"
+
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/pencil-${pkgver}"
+
+ make install INSTALL_ROOT="${pkgdir}"
+ rm -rf "${pkgdir}/usr/lib"
+}