summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Robin2015-06-11 20:49:02 +0200
committerBenjamin Robin2015-06-11 20:49:02 +0200
commit9b01816a581cf55502d220040416e25499762e2f (patch)
treead41d5c9875196a12779e69fa755cc429e533f20
downloadaur-9b01816a581cf55502d220040416e25499762e2f.tar.gz
Copied from AUR 3
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--pencil2d.desktop6
-rw-r--r--pencil2d.install11
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b71b8e4e2c3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pencil2d-git
+ pkgdesc = Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics
+ pkgver = 1413.2630deb
+ pkgrel = 1
+ url = http://www.pencil2d.org/
+ install = pencil2d.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = qt5-tools
+ depends = ming
+ depends = ffmpeg
+ depends = qt5-svg
+ depends = qt5-multimedia
+ provides = pencil2d
+ conflicts = pencil2d
+ source = pencil2d::git+https://github.com/pencil2d/pencil.git
+ source = pencil2d.desktop
+ md5sums = SKIP
+ md5sums = 98008076937080db82a939d8129ed2d0
+
+pkgname = pencil2d-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97e06a891933
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Otto VonStein <otto>
+# Contributor: ex-maintainer Benjamin Robin <benjarobin>
+
+pkgname=pencil2d-git
+_gitname=pencil2d
+pkgver=1413.2630deb
+pkgrel=1
+pkgdesc="Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics"
+arch=('i686' 'x86_64')
+url="http://www.pencil2d.org/"
+license=('GPL')
+depends=('ming' 'ffmpeg' 'qt5-svg' 'qt5-multimedia')
+makedepends=('git' 'qt5-tools')
+provides=('pencil2d')
+conflicts=('pencil2d')
+install=pencil2d.install
+source=('pencil2d::git+https://github.com/pencil2d/pencil.git'
+ 'pencil2d.desktop')
+md5sums=('SKIP'
+ '98008076937080db82a939d8129ed2d0')
+
+pkgver()
+{
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare()
+{
+ cd "${_gitname}"
+ #patch -p1 -i "${srcdir}/pencil2d.patch"
+}
+
+build()
+{
+ cd "${_gitname}"
+ msg "Starting qmake..."
+ qmake
+ msg "Starting make..."
+ make
+}
+
+package()
+{
+ cd "${_gitname}"
+ install -D -m755 app/Pencil2D "${pkgdir}/usr/bin/pencil2d"
+ install -D -m644 icons/icon.png "${pkgdir}/usr/share/pixmaps/pencil2d.png"
+ install -D -m644 "${srcdir}/pencil2d.desktop" "${pkgdir}/usr/share/applications/pencil2d.desktop"
+}
+
diff --git a/pencil2d.desktop b/pencil2d.desktop
new file mode 100644
index 000000000000..8575f7955b1f
--- /dev/null
+++ b/pencil2d.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=Pencil
+Exec=pencil2d %F
+Icon=pencil2d
+Categories=Graphics;2DGraphics;
diff --git a/pencil2d.install b/pencil2d.install
new file mode 100644
index 000000000000..cab774317d00
--- /dev/null
+++ b/pencil2d.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file