summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2020-10-02 19:24:57 +0200
committerPopolon2020-10-02 19:24:57 +0200
commitf1358fa7048390f95a3ec297e1b7b480b02762a2 (patch)
tree595a72bc49ba9505d2d637b9296a6c6c5ec12eff
downloadaur-f1358fa7048390f95a3ec297e1b7b480b02762a2.tar.gz
initial pencil2d-mypaint-git commit version
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
-rw-r--r--pencil2d.install11
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a4fcb7af887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pencil2d-mypaint-git
+ pkgdesc = Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics with mypaint brushes extension testing branch
+ pkgver = 4505.1fc3f62a
+ pkgrel = 1
+ url = http://www.pencil2d.org/
+ install = pencil2d.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = qt5-tools
+ depends = ming
+ depends = ffmpeg
+ depends = qt5-svg
+ depends = qt5-multimedia
+ depends = qt5-xmlpatterns
+ provides = pencil2d
+ conflicts = pencil2d
+ options = !staticlibs
+ source = pencil2d::git+https://github.com/CandyFace/pencil.git
+ md5sums = SKIP
+
+pkgname = pencil2d-mypaint-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f0cde8ffdde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Benjamin Robin <dev@benjarobin.fr>
+# Contributor: Otto VonStein <otto>
+
+pkgname=pencil2d-mypaint-git
+_gitname=pencil2d
+pkgver=4505.1fc3f62a
+pkgrel=1
+pkgdesc="Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics with mypaint brushes extension testing branch"
+arch=('i686' 'x86_64')
+url="http://www.pencil2d.org/"
+license=('GPL')
+depends=('ming' 'ffmpeg' 'qt5-svg' 'qt5-multimedia' 'qt5-xmlpatterns')
+makedepends=('git' 'qt5-tools')
+provides=('pencil2d')
+conflicts=('pencil2d')
+options=('!staticlibs')
+install=pencil2d.install
+source=('pencil2d::git+https://github.com/CandyFace/pencil.git')
+md5sums=('SKIP')
+
+pkgver()
+{
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build()
+{
+ cd "${_gitname}"
+ git checkout implement_mypaint_nobitmapsurface
+
+ msg "Starting qmake..."
+ qmake PREFIX=/usr
+ msg "Starting make..."
+ make
+}
+
+package()
+{
+ cd "${_gitname}"
+ make install INSTALL_ROOT="${pkgdir}"
+}
diff --git a/pencil2d.install b/pencil2d.install
new file mode 100644
index 000000000000..cab774317d00
--- /dev/null
+++ b/pencil2d.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file