summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuck Melanoma2021-04-11 15:46:27 -0700
committerBuck Melanoma2021-04-11 15:46:27 -0700
commit0a90c19ec412815938c96d25c5cfb5717d45878d (patch)
tree94155f110c5a5f318d9616b4e920208190fc6222
downloadaur-0a90c19ec412815938c96d25c5cfb5717d45878d.tar.gz
Initial PKGBUILD commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bd023112877
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pengupop
+ pkgdesc = Clone of the retro arcade game Bust-a-move
+ pkgver = 2.2.2
+ pkgrel = 26
+ url = http://www.junoplay.com/pengupop
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ optdepends =
+ source = https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/p/pengupop-2.2.2-26.fc34.x86_64.rpm
+ sha256sums = 399eb8be430f4d435cebd6b2817bd3f784ca555e8405c378cd3cced20c2de2f3
+
+pkgname = pengupop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57f20208b57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: uint2048_t
+# report pkgbuild bugs to uint2048_t
+# report game bugs to morten@rashbox.org
+
+pkgname=pengupop
+pkgver=2.2.2
+pkgrel=26
+pkgdesc="Clone of the retro arcade game Bust-a-move"
+arch=('i686' 'x86_64')
+url='http://www.junoplay.com/pengupop'
+license=('GPL')
+depends=('sdl')
+optdepends=('')
+source=("https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/p/pengupop-2.2.2-26.fc34.x86_64.rpm")
+sha256sums=('399eb8be430f4d435cebd6b2817bd3f784ca555e8405c378cd3cced20c2de2f3')
+
+package() {
+ install -Dm755 usr/bin/pengupop "$pkgdir"/usr/bin/pengupop
+ install -Dm755 usr/share/applications/pengupop.desktop "$pkgdir"/usr/share/applications/pengupop.desktop
+ install -Dm755 usr/share/icons/hicolor/48x48/apps/pengupop.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/pengupop.png
+
+}
+