summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Nagel2025-01-23 09:49:34 +0100
committerGeorg Nagel2025-01-23 09:49:34 +0100
commit4db3e4f3f0a273e29d082c7633cba83ce10343b6 (patch)
tree4ca0af8b63f3e8c245e268c99396619c79193399
parent857a2883a9b6c271ba1836a74904864cc124c6cc (diff)
downloadaur-4db3e4f3f0a273e29d082c7633cba83ce10343b6.tar.gz
fix variables
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88cefb795bf6..35ff4921de18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = penpot
pkgdesc = The open-source design tool for design and code collaboration
pkgver = 2.4.2
- pkgrel = 2
+ pkgrel = 3
url = https://penpot.app
arch = x86_64
license = MPL-2.0
diff --git a/PKGBUILD b/PKGBUILD
index 54cc47766cb1..f99ab90b76ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=penpot
pkgname=(penpot penpot-exporter penpot-frontend)
pkgver=2.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="The open-source design tool for design and code collaboration "
arch=('x86_64')
url="https://penpot.app"
@@ -36,15 +36,13 @@ sha256sums=(
'29f5cde4d5ba6d73b14d6fd88a0be930c6bcf5eff3512332cba50a30316c6621'
)
-prepare() {
+build() {
export YARN_CACHE_FOLDER="${srcdir}/.yarn-cache"
export RUSTUP_HOME=${srcdir}/.rustup
export CARGO_HOME=${srcdir}/.cargo
export RUST_VERSION=1.82.0
export JAVA_HOME=/usr/lib/jvm/$(archlinux-java status | grep 21 | head -n 1 | tr -d '[:space:]')/
-}
-build() {
echo "==== BULDING FRONTEND"
cd "${srcdir}/${_pkgbase}-${pkgver}/frontend"
# we dont have yarn @ version 4 as package, so use yarn 1.x
@@ -56,7 +54,7 @@ build() {
sed -i 's/\.git#commit=/.git#/' package.json
sed -i 's#/usr/local/emsdk/emsdk_env.sh#/usr/bin/emsdk_env.sh#' ../render-wasm/build
- rustup install $RUST_VERISON
+ rustup install $RUST_VERSION
rustup default $RUST_VERSION
rustup target add wasm32-unknown-emscripten