summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZorinFoss2023-11-02 07:24:03 +0200
committerZorinFoss2023-11-02 07:24:03 +0200
commitf7a95a01ecef08ae554203d118b70c7ebeb9479b (patch)
tree8e106363c5f6d61f0ebe0197151dc7d23b86adea
parent3367e1db9d633722eac1127d1485d6f9fa651834 (diff)
downloadaur-f7a95a01ecef08ae554203d118b70c7ebeb9479b.tar.gz
add missed dependencies
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8bdf559496d..844171999104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgrel=1
pkgdesc="Penpot Desktop delivers a desktop-like experience for Penpot users with the additional of integrating tabs to conveniently traverse back and forth between projects."
arch=('x86_64')
conflicts=("penpot-desktop")
-depends=('re2')
+depends=("c-ares" "ffmpeg" "gtk3" "http-parser" "libevent" "libvpx" "libxslt" "libxss" "minizip" "nss" "re2" "snappy" "libnotify" "libappindicator-gtk3")
url="https://sudovanilla.com/code/Korbs/Penpot-Desktop/"
license=('MIT')
_filename=Penpot-Desktop-${pkgver}.pacman
@@ -17,6 +17,9 @@ package() {
tar -xJv -C "${pkgdir}" -f "${srcdir}/${_filename}" usr opt
mkdir "$pkgdir/usr/bin"
ln -s "/opt/Penpot Desktop" "$pkgdir/usr/bin/penpot-desktop"
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/Penpot Desktop/chrome-sandbox' || true
}