summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-04-20 14:15:44 +0200
committerfelics2018-04-20 14:15:44 +0200
commit86874fe8d46b35392f0eb5b1b1ca931bd62a0a0d (patch)
treef41a06331ace334035924fac47654e45a86654f4
downloadaur-86874fe8d46b35392f0eb5b1b1ca931bd62a0a0d.tar.gz
Initial_Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD127
-rw-r--r--pentaxpj.conf.a418
-rw-r--r--pentaxpj.conf.letter18
4 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38455af355d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pentaxpj-filter
+ pkgdesc = Printer filter for Pentax PocketJet 200 and PocketJet II printers. Needed in addition to the PPDs/ files that come with foomatic-db/ CUPS.
+ pkgver = 1.0.0
+ pkgrel = 1
+ epoch = 0
+ url = http://ww1.pragana.net/gdiprinters.html#pentaxpj
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gzip
+ depends = ghostscript
+ optdepends = tk: For GUI to change config file for LPD usage.
+ backup = etc/pentaxpj.conf
+ source = pentaxpj-1.0.0.tar.gz::http://ww1.pragana.net/pentaxpj-1.0.0.tar.gz
+ source = pentaxpj.conf.a4
+ source = pentaxpj.conf.letter
+ sha256sums = e1ea36e1cdfcc733c69709717fb1ed97f2fd0f3e3a12197309277007df1b819b
+ sha256sums = 402f62fef43ca1738d7ba8e7729864326ca138fa5a57fb0b46611f05585ed4c4
+ sha256sums = a2e25b291591b31b215a7001308f76b1ea7ece2eb803a7258f821bae1223c51a
+
+pkgname = pentaxpj-filter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..625f84133cbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,127 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2018-04-20.
+
+_pkgname=pentaxpj-filter
+pkgname="${_pkgname}"
+epoch=0
+_pkgver=1.0.0
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="Printer filter for Pentax PocketJet 200 and PocketJet II printers. Needed in addition to the PPDs/ files that come with foomatic-db/ CUPS."
+arch=('i686' 'x86_64')
+url="http://ww1.pragana.net/gdiprinters.html#pentaxpj"
+license=('GPL')
+
+# groups=(
+# "pentaxpj"
+# )
+
+depends=(
+ "ghostscript"
+)
+
+makedepends=(
+ "gzip"
+ # "tk"
+)
+
+optdepends=(
+ "tk: For GUI to change config file for LPD usage."
+)
+
+# provides=(
+ # "${_pkgname}=${pkgver}"
+# )
+
+# conflicts=(
+ # "${_pkgname}"
+# )
+
+# replaces=(
+ # "${_pkgname}<=${pkgver}"
+# )
+
+backup=(
+ "etc/pentaxpj.conf"
+)
+
+_target="pentaxpj-${_pkgver}.tar.gz"
+
+source=(
+ "${_target}::http://ww1.pragana.net/pentaxpj-${_pkgver}.tar.gz"
+ "pentaxpj.conf.a4"
+ "pentaxpj.conf.letter"
+)
+
+sha256sums=(
+ "e1ea36e1cdfcc733c69709717fb1ed97f2fd0f3e3a12197309277007df1b819b"
+ "402f62fef43ca1738d7ba8e7729864326ca138fa5a57fb0b46611f05585ed4c4"
+ "a2e25b291591b31b215a7001308f76b1ea7ece2eb803a7258f821bae1223c51a"
+)
+
+build() {
+ cd "${srcdir}/pentaxpj"
+
+ make
+
+ gunzip test-page.ps.gz
+ gzip -9 test-page.ps
+}
+
+package() {
+ _instdirbase="/opt/${_pkgname}"
+ _instdir="${pkgdir}/${_instdirbase}"
+ _bindirbase="/usr/bin"
+ _bindir="${pkgdir}/${_execdirbase}"
+ _filterdirbase="/usr/lib/cups/filter"
+ _filterdir="${pkgdir}/${_filterdirbase}"
+ _spooldirbase="/var/spool/lpd"
+ _spooldir="${pkgdir}/${_spooldirbase}"
+ _etcdirbase="/etc"
+ _etcdir="${pkgdir}/${_etcdirbase}"
+ _docdirbase="/usr/share/doc/${_pkgname}"
+ _docdir="${pkgdir}/${_docdirbase}"
+
+ cd "${_srcdir}"
+
+ install -v -d -m755 "${_instdir}"
+ (
+ cd pentaxpj
+ for _target in BWidget-* pentax.xpm pentaxpj pentaxpj_sh pentaxsetup test-page.ps.gz; do
+ cp -av "${_target}" "${_instdir}"/
+ done
+ chown root:lp "${_instdir}"/{pentaxsetup,pentaxpj,pentaxpj_sh}
+ chmod 754 "${_instdir}"/pentaxsetup
+ chmod 755 "${_instdir}"/{pentaxpj,pentaxpj_sh}
+
+ install -v -D -m644 README "${_docdir}"/README
+ )
+
+ for _docfile in pentaxpj.conf.*; do
+ install -v -D -m644 "${srcdir}/${_docfile}" "${_docdir}/${_docfile}"
+ done
+
+ install -v -D -m664 -g lp pentaxpj.conf.a4 "${_etcdir}"/pentaxpj.conf
+
+ (
+ cd "${_docdir}"
+ ln -sv "${_instdirbase}"/test-page.ps.gz .
+ )
+
+ install -v -d -m755 "${_bindir}"
+ (
+ cd "${_bindir}"
+ ln -sv "${_instdirbase}"/pentaxpj_sh pentaxpj_sh
+ ln -sv "${_instdirbase}"/pentaxpj pentaxpj
+ ln -sv "${_instdirbase}"/pentaxsetup .
+ )
+
+ install -v -d -m755 "${_filterdir}"
+ (
+ cd "${_filterdir}"
+ ln -sv "${_instdirbase}"/pentaxpj_sh pentaxpj
+ )
+
+ install -v -d -m775 -g lp "${_spooldir}"
+}
diff --git a/pentaxpj.conf.a4 b/pentaxpj.conf.a4
new file mode 100644
index 000000000000..5fe1b68581b2
--- /dev/null
+++ b/pentaxpj.conf.a4
@@ -0,0 +1,18 @@
+#-s a4 -g 2481x3507 -T -d 7 -f 1 -a 300
+array set settings {
+model 0
+driverpath /opt/pentaxpj-filter
+showport "/dev/usb/lp0 (USB1)"
+port /dev/usb/lp0
+headerpage 0
+paper 0
+density 7
+quality 0
+feedmode 1
+extrafeed 300
+width 8.27
+height 11.69
+tofile 0
+tofilename /tmp/output.lp
+spooldir /var/spool/lpd
+}
diff --git a/pentaxpj.conf.letter b/pentaxpj.conf.letter
new file mode 100644
index 000000000000..4651baa2e460
--- /dev/null
+++ b/pentaxpj.conf.letter
@@ -0,0 +1,18 @@
+#-s letter -g 2550x3300 -T -d 7 -f 1 -a 300
+array set settings {
+model 0
+driverpath /opt/pentaxpj-filter
+showport "/dev/usb/lp0 (USB1)"
+port /dev/usb/lp0
+headerpage 0
+paper 0
+density 7
+quality 0
+feedmode 1
+extrafeed 300
+width 8.50
+height 11.00
+tofile 0
+tofilename /tmp/output.lp
+spooldir /var/spool/lpd
+}