summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillermo Ramos2015-06-08 12:41:35 +0200
committerGuillermo Ramos2015-06-08 12:41:35 +0200
commit28eb6013a40448bf68a542cc8d073ad1f746c4de (patch)
tree2e100c4ebf3537cce3a080c3e07286292342f3f7
downloadaur-28eb6013a40448bf68a542cc8d073ad1f746c4de.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--launcher.sh4
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efc8dc1e582a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pentbox
+ pkgdesc = A security suite that packs security and stability testing oriented tools for networks and systems.
+ pkgver = 1.5
+ pkgrel = 6
+ url = http://www.pentbox.net
+ arch = any
+ license = GPL3
+ depends = ruby
+ optdepends = hping: TCP SYN flood with hping3
+ options = !strip
+ source = http://sourceforge.net/projects/pentbox/files/1.5/pentbox-1.5.tar/download
+ source = launcher.sh
+ md5sums = ec073e657923e3fde8bf15c5ab1e53fe
+ md5sums = c93d1d00bbedba174fa2d6fea8b32b3c
+ sha256sums = cb2cb605453e68a3fe9e53369d32d6985991d2243d8bd03429c150f070e3982e
+ sha256sums = c473d132034b58413a78016238f38288eca18ab7d4f0adf3ad70793379637c42
+
+pkgname = pentbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc5ff7f9613
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guillermo Ramos <0xwille at gmail dot com>
+
+pkgname="pentbox"
+pkgver=1.5
+pkgrel=6
+pkgdesc="A security suite that packs security and stability testing oriented tools for networks and systems."
+arch=(any)
+url="http://www.pentbox.net"
+license=('GPL3')
+depends=(ruby)
+optdepends=('hping: TCP SYN flood with hping3')
+options=(!strip)
+source=("http://sourceforge.net/projects/pentbox/files/$pkgver/$pkgname-$pkgver.tar/download"
+ "launcher.sh")
+md5sums=("ec073e657923e3fde8bf15c5ab1e53fe"
+ "c93d1d00bbedba174fa2d6fea8b32b3c")
+sha256sums=("cb2cb605453e68a3fe9e53369d32d6985991d2243d8bd03429c150f070e3982e"
+ "c473d132034b58413a78016238f38288eca18ab7d4f0adf3ad70793379637c42")
+
+package() {
+ # Install to /opt/pentbox
+ mkdir -p $pkgdir/opt/$pkgname
+ cp -R $srcdir/$pkgname-$pkgver/* $pkgdir/opt/$pkgname/
+ rm -rf $(find $pkgdir/opt/$pkgname/ -type d -name .svn)
+
+ # Install launcher
+ install -D -m755 launcher.sh $pkgdir/usr/bin/$pkgname
+
+ # Fix permissions
+ chmod -R 755 $pkgdir/opt/$pkgname
+ find $pkgdir/opt/$pkgname -type f -name "*.txt" -exec chmod 644 {} \;
+}
diff --git a/launcher.sh b/launcher.sh
new file mode 100644
index 000000000000..7892848aa35b
--- /dev/null
+++ b/launcher.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/pentbox
+ruby pentbox.rb