summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2021-03-31 16:52:51 +0200
committerTheJackiMonster2021-03-31 16:52:51 +0200
commit59e1fd226d94e9f7515da752cec24eb6cf6a8ea9 (patch)
tree8eedf42fee58677d5a9a3b5572668c06663fca53
downloadaur-59e1fd226d94e9f7515da752cec24eb6cf6a8ea9.tar.gz
Initial commit
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aedf614ef1d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pep-engine-git
+ pkgdesc = A Free Software library for automatic key management and encryption of messages.
+ pkgver = 2.1.24
+ pkgrel = 1
+ url = https://pep.software
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = asn1c
+ makedepends = make
+ makedepends = yml2
+ depends = gpgme
+ depends = sqlite
+ depends = sequoia
+ provides = pep-engine
+ source = git+https://gitea.pep.foundation/pEp.foundation/pEpEngine.git
+ md5sums = SKIP
+
+pkgname = pep-engine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..677056b3db0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+_pkgname=pep-engine
+pkgname=$_pkgname-git
+pkgver=2.1.24
+pkgrel=1
+pkgdesc="A Free Software library for automatic key management and encryption of messages."
+arch=('x86_64' 'i686')
+url='https://pep.software'
+license=('GPL3')
+makedepends=('git' 'asn1c' 'make' 'yml2')
+depends=('gpgme' 'sqlite' 'sequoia')
+provides=('pep-engine')
+source=("git+https://gitea.pep.foundation/pEp.foundation/pEpEngine.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/pEpEngine"
+
+ echo "PREFIX=$pkgdir/usr" > 'local.conf'
+ echo "PER_MACHINE_DIRECTORY=$pkgdir/usr/share/pEp" >> 'local.conf'
+ echo "YML2_PATH=/usr/bin" >> 'local.conf'
+}
+
+pkgver() {
+ cd "$srcdir/pEpEngine"
+
+ git tag | grep "^Release" | grep -v RC | sort -V -r | head -1 | tr '_-' ' ' | awk '{print $2}'
+}
+
+build() {
+ cd "$srcdir/pEpEngine"
+
+ make
+ make db
+}
+
+package() {
+ cd "$srcdir/pEpEngine"
+
+ make install
+ make dbinstall
+}
+