summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeimos2018-12-01 19:05:40 -0500
committerDeimos2018-12-01 19:05:40 -0500
commit71cae4f42ba780adf2c49dc4e2784319ba019300 (patch)
tree60051bbf4976a20c182124b99868fd82de014e17
downloadaur-71cae4f42ba780adf2c49dc4e2784319ba019300.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..626a51228dc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = performance
+ pkgdesc = High-Performance library for Data Structures manipulation
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/gnustep/libs-performance
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-libs
+ license = GPL
+ source = https://github.com/gnustep/libs-performance/archive/performance-0_5_0.tar.gz
+ sha256sums = fb17a1fb812f3e176b087a56ff753f1148e4bdca0103ed0113f21a5cb1c9a669
+
+pkgname = performance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1422dbd57374
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=performance
+pkgname=performance
+pkgrel=1
+pkgver=0.5.0
+pkgdesc='High-Performance library for Data Structures manipulation'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/gnustep/libs-performance'
+license=('GPL')
+groups=('gnustep-libs')
+source=("https://github.com/gnustep/libs-performance/archive/performance-0_5_0.tar.gz")
+sha256sums=('fb17a1fb812f3e176b087a56ff753f1148e4bdca0103ed0113f21a5cb1c9a669')
+
+build() {
+ cd "libs-performance-performance-0_5_0"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd libs-performance-performance-0_5_0
+ make DESTDIR="$pkgdir" install
+}