summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:48:06 +0000
committerJames Harvey2015-07-17 21:48:06 +0000
commit10d3e33e1999745bd9747737a6ef4ab9dcc6102b (patch)
treea2148f871d6d41523e4ebec9d86e9ab8d6948e3e
downloadaur-10d3e33e1999745bd9747737a6ef4ab9dcc6102b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e99a7be6498f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perftest
+ pkgdesc = OpenFabrics Alliance Infiniband verbs performance testing and benchmarking tools
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = librdmacm
+ depends = libibumad
+ depends = bash
+ source = https://www.openfabrics.org/downloads/perftest/perftest-3.0-0.9.g214990b.tar.gz
+ md5sums = 527cc1b725229bd841e2605e88baf7ce
+
+pkgname = perftest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdde3f6bf581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * No namcap warnings or errors
+
+pkgname=perftest
+pkgver=3.0
+_pkgver_subver=0.9
+_pkgver_commit=g214990b
+pkgrel=1
+pkgdesc='OpenFabrics Alliance Infiniband verbs performance testing and benchmarking tools'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('librdmacm' 'libibumad' 'bash')
+source=("https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}.${_pkgver_commit}.tar.gz")
+md5sums=('527cc1b725229bd841e2605e88baf7ce')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm755 runme "${pkgdir}/usr/bin/perftest-runme"
+}