summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2018-10-30 22:39:25 +0100
committerayekat2018-10-30 22:39:25 +0100
commite8d2cbecb6ba88853379098b6cd9f80fb57b519d (patch)
tree3b7bb4994c446050f9a1d241241970efb132b338
downloadaur-e8d2cbecb6ba88853379098b6cd9f80fb57b519d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD52
-rw-r--r--perfutils.pc10
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a8494ac9fb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perfutils-git
+ pkgdesc = Collection of eclectic tools for measuring performance using the cycle counter and pinning threads
+ pkgver = r94.5676231
+ pkgrel = 1
+ url = https://github.com/PlatformLab/PerfUtils
+ arch = x86_64
+ license = custom:ISC
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ provides = perfutils
+ conflicts = perfutils
+ source = git+https://github.com/PlatformLab/PerfUtils
+ source = perfutils.pc
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = perfutils-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..075a9a2e10e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/PerfUtils/
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95c8aba97919
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Tinu Weber <http://ayekat.ch>
+
+pkgname=perfutils-git
+pkgver=r94.5676231
+pkgrel=1
+arch=(x86_64)
+
+pkgdesc='Collection of eclectic tools for measuring performance using the cycle counter and pinning threads'
+license=('custom:ISC')
+url='https://github.com/PlatformLab/PerfUtils'
+
+source=('git+https://github.com/PlatformLab/PerfUtils'
+ perfutils.pc)
+sha256sums=(SKIP
+ SKIP)
+
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+
+depends=(gcc-libs glibc)
+makedepends=(git)
+
+pkgver() {
+ cd PerfUtils
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd PerfUtils
+ make
+ g++ -shared obj/*.o -o obj/libPerfUtils.so
+}
+
+package() {
+ cd PerfUtils
+
+ # libraries
+ install -dm0755 "$pkgdir"/usr/lib
+ install -Dm0755 obj/libPerfUtils.{a,so} "$pkgdir"/usr/lib/
+ ln -sf libPerfUtils.so "$pkgdir"/usr/lib/libPerfUtils.so.0
+
+ # headers
+ install -dm0755 "$pkgdir"/usr/include/PerfUtils
+ install -m0644 include/PerfUtils/* "$pkgdir"/usr/include/PerfUtils/
+
+ # pkgconf
+ install -Dm0644 "$srcdir"/perfutils.pc "$pkgdir"/usr/lib/pkgconfig/perfutils.pc
+
+ # misc
+ install -Dm0644 README.md "$pkgdir"/usr/share/doc/"${pkgname%-git}"/README.md
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-git}"/LICENSE
+}
diff --git a/perfutils.pc b/perfutils.pc
new file mode 100644
index 000000000000..c0d6d6001108
--- /dev/null
+++ b/perfutils.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: perfutils
+Description: Measure performance using the cycle counter and pinning
+Version: 0
+Cflags: -I${includedir}
+Libs: -L${libdir} -lPerfUtils