summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan Tascon2015-06-17 16:53:25 -0500
committerJuan Tascon2015-06-17 16:53:25 -0500
commitb3e887d4d089b30e34e4df971d4de8375d01e431 (patch)
treebf3b72757e5872b606344e52fa102584a542a227
downloadaur-periscope-git.tar.gz
initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ea2f82aef0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = periscope-git
+ pkgdesc = Subtitles searching module written in python.
+ pkgver = 20121120
+ pkgrel = 4
+ url = https://github.com/patrickdessalle/periscope
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2-beautifulsoup3
+ provides = periscope
+ provides = periscope-svn
+ conflicts = periscope
+ conflicts = periscope-svn
+
+pkgname = periscope-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c80a57f3286c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: juantascon <juantascon.aur@horlux.org>
+
+pkgname=periscope-git
+pkgver=20121120
+pkgrel=4
+pkgdesc="Subtitles searching module written in python."
+url="https://github.com/patrickdessalle/periscope"
+arch=('any')
+license=('GPL3')
+depends=('python2-beautifulsoup3')
+makedepends=('git' 'python2-setuptools')
+conflicts=('periscope' 'periscope-svn')
+provides=('periscope' 'periscope-svn')
+
+_gitroot="https://github.com/patrickdessalle/periscope.git"
+_gitname="periscope"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+