summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-09-25 21:08:26 +0200
committerPiotr Rogoża2017-09-25 21:08:26 +0200
commitf3e57691a2d6b3096f4bbbc16be97fedbd4e8e03 (patch)
treed9ddcf3c8cf002ed1e81963b1894b01c8398bfa8
downloadaur-f3e57691a2d6b3096f4bbbc16be97fedbd4e8e03.tar.gz
Added new package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f31b3636644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Sep 25 19:07:57 UTC 2017
+pkgbase = perl-alien-build
+ pkgdesc = Alien::Build::MM - Alien::Build installer code for ExtUtils::MakeMaker
+ pkgver = 1.18
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Alien-Build/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-alien-base-modulebuild
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/Alien-Build-1.18.tar.gz
+ sha256sums = 8ebeaffcda2bac6fe65b64458d8c69865cf3275dce6fd6471861671ea97616f9
+
+pkgname = perl-alien-build
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58af06e4b02e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+
+pkgname=perl-alien-build
+pkgver=1.18
+pkgrel=1
+_author="P/PL/PLICEASE"
+_perlmod="Alien-Build"
+pkgdesc="Alien::Build::MM - Alien::Build installer code for ExtUtils::MakeMaker"
+arch=('any')
+url="http://search.cpan.org/dist/Alien-Build/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+makedepends=(perl-alien-base-modulebuild)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('8ebeaffcda2bac6fe65b64458d8c69865cf3275dce6fd6471861671ea97616f9')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
+ make
+ else
+ perl Build.PL
+ ./Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make test
+ else
+ ./Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ fi
+}
+