summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElias Elwyn2024-02-14 12:47:19 +1100
committerElias Elwyn2024-02-14 12:51:51 +1100
commitddbae411dd7f90184e7127a0f18d83c0a992b50a (patch)
tree8a6899d13dd4e325e93e641977c0b8b973703dbe
downloadaur-ddbae411dd7f90184e7127a0f18d83c0a992b50a.tar.gz
feat: add PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD44
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c774578fd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-alien-build-plugin-cleanse-builddir
+ pkgdesc = Alien::Build plugin to cleanse the build dir after the build phase
+ pkgver = 0.06
+ pkgrel = 1
+ url = https://metacpan.org/release/Alien-Build-Plugin-Cleanse-BuildDir
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl-capture-tiny
+ checkdepends = perl-data-dump
+ checkdepends = perl-test2-suite
+ depends = perl
+ depends = perl-alien-build
+ depends = perl-path-tiny
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/S/SL/SLAFFAN/Alien-Build-Plugin-Cleanse-BuildDir-0.06.tar.gz
+ sha256sums = e0290b4891a18068db109c3001c6c8f1c900a28568dcaaa78d4dd0b69216d666
+
+pkgname = perl-alien-build-plugin-cleanse-builddir
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c906e75958f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7897d4fd2134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Elias Elwyn <a@jthv.ai>
+
+pkgname=perl-alien-build-plugin-cleanse-builddir
+pkgver=0.06
+pkgrel=1
+pkgdesc='Alien::Build plugin to cleanse the build dir after the build phase'
+_dist=Alien-Build-Plugin-Cleanse-BuildDir
+arch=(any)
+url="https://metacpan.org/release/$_dist"
+license=(GPL PerlArtistic)
+depends=(
+ perl
+ perl-alien-build
+ perl-path-tiny
+)
+checkdepends=(
+ perl-capture-tiny
+ perl-data-dump
+ perl-test2-suite
+)
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/S/SL/SLAFFAN/$_dist-$pkgver.tar.gz")
+sha256sums=(e0290b4891a18068db109c3001c6c8f1c900a28568dcaaa78d4dd0b69216d666)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}