summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2021-01-07 13:49:58 +0300
committerAnton Leontiev2021-01-07 13:49:58 +0300
commit8fce7cc6f9194b6f27df7c7ac3c3ea752fbdd9ea (patch)
tree8d915ebdf44fc6e78820d256494a47235554af3a
parent53bd87eace60e89a2f4ccf10afc5057907dbd0c8 (diff)
downloadaur-8fce7cc6f9194b6f27df7c7ac3c3ea752fbdd9ea.tar.gz
perl-alien-gsl: Update to v1.02
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--PKGBUILD.tt3
3 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2af745df10a..bb7db1a83d24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-alien-gsl
pkgdesc = Building, finding and using GSL library
- pkgver = 1.01
+ pkgver = 1.02
pkgrel = 1
url = https://metacpan.org/release/Alien-GSL
arch = any
@@ -8,11 +8,13 @@ pkgbase = perl-alien-gsl
license = GPL
makedepends = perl-module-build>=0.38
makedepends = perl-alien-base-modulebuild
+ makedepends = perl-net-ssleay
+ makedepends = perl-io-socket-ssl
depends = perl-alien-build
depends = gsl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/J/JB/JBERGER/Alien-GSL-1.01.tar.gz
- md5sums = 7d7aa5fc9e3e28bebdecb991fdfd5882
+ source = http://search.cpan.org/CPAN/authors/id/J/JB/JBERGER/Alien-GSL-1.02.tar.gz
+ md5sums = 91ad561f5420e59a70a09ae7bb0a806d
pkgname = perl-alien-gsl
diff --git a/PKGBUILD b/PKGBUILD
index edc61e66def8..ac2dc9a9f8bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,18 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-alien-gsl
-pkgver=1.01
+pkgver=1.02
pkgrel=1
pkgdesc='Building, finding and using GSL library'
arch=('any')
url='https://metacpan.org/release/Alien-GSL'
license=('PerlArtistic' 'GPL')
-makedepends=('perl-module-build>=0.38' 'perl-alien-base-modulebuild')
+makedepends=('perl-module-build>=0.38' 'perl-alien-base-modulebuild' 'perl-net-ssleay'
+ 'perl-io-socket-ssl')
depends=('perl-alien-build' 'gsl')
-source=(http://search.cpan.org/CPAN/authors/id/J/JB/JBERGER/Alien-GSL-1.01.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/J/JB/JBERGER/Alien-GSL-1.02.tar.gz)
options=(!emptydirs)
-md5sums=('7d7aa5fc9e3e28bebdecb991fdfd5882')
+md5sums=('91ad561f5420e59a70a09ae7bb0a806d')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,20 +22,20 @@ sanitize() {
}
build() {
- cd Alien-GSL-1.01
+ cd Alien-GSL-1.02
sanitize
/usr/bin/perl Build.PL --installdirs vendor --destdir "$pkgdir"
/usr/bin/perl Build
}
check() {
- cd Alien-GSL-1.01
+ cd Alien-GSL-1.02
sanitize
/usr/bin/perl Build test
}
package() {
- cd Alien-GSL-1.01
+ cd Alien-GSL-1.02
sanitize
/usr/bin/perl Build install
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index bcbccfd67ad8..bc9f54959db1 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,7 +9,8 @@ pkgdesc='Building, finding and using GSL library'
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-makedepends=('perl-module-build>=0.38' 'perl-alien-base-modulebuild')
+makedepends=('perl-module-build>=0.38' 'perl-alien-base-modulebuild' 'perl-net-ssleay'
+ 'perl-io-socket-ssl')
depends=('perl-alien-build' 'gsl')
source=([% source %])
options=(!emptydirs)