summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-06-20 23:05:49 +0200
committerPiotr Rogoża2017-06-20 23:05:49 +0200
commit8d8bbaed904fb43ff92d30f75c1a83acb5e7704b (patch)
treea93780c4642a5936103431b7931206945e34c834
downloadaur-8d8bbaed904fb43ff92d30f75c1a83acb5e7704b.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD52
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a251fed399d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jun 20 21:01:40 UTC 2017
+pkgbase = perl-alien-hunspell
+ pkgdesc = Alien::Hunspell - Install hunspell
+ pkgver = 0.08
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Alien-Hunspell/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl-test-cchecker
+ depends = perl-alien-base
+ depends = perl-ffi-checklib
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/Alien-Hunspell-0.08.tar.gz
+ sha256sums = c23d0870ba8ce4f2ab0af0093ee29ed9fa23f14b3c21fa05e9996cddb54326ca
+
+pkgname = perl-alien-hunspell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a012292a6cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+
+pkgname=perl-alien-hunspell
+pkgver=0.08
+pkgrel=1
+_author="P/PL/PLICEASE"
+_perlmod="Alien-Hunspell"
+pkgdesc="Alien::Hunspell - Install hunspell"
+arch=('any')
+url="http://search.cpan.org/dist/Alien-Hunspell/"
+license=('GPL' 'PerlArtistic')
+depends=(
+perl-alien-base
+perl-ffi-checklib
+)
+checkdepends=(perl-test-cchecker)
+makedepends=(perl-module-build)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('c23d0870ba8ce4f2ab0af0093ee29ed9fa23f14b3c21fa05e9996cddb54326ca')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ else
+ /usr/bin/perl Build.PL
+ ./Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make test
+ else
+ ./Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ fi
+}
+