summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2014-04-08 01:03:59 +0000
committerKyle Keen2014-04-08 01:03:59 +0000
commit196a55b555e4babe932308ec90e000de5b291f95 (patch)
treef0fd23c4b6ca9615634ace56d3f802967bd964ae
parenteed0ae4031c21aae8cc065b8f9342046540fe7e6 (diff)
downloadaur-196a55b555e4babe932308ec90e000de5b291f95.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19b691ea1f22..ec371a0bcf75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = perl-alien-wxwidgets
depends = wxgtk2.8
depends = perl-module-pluggable
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-0.65.tar.gz
+ source = http://www.cpan.org/modules/by-module/Alien/Alien-wxWidgets-0.65.tar.gz
md5sums = 219a4f572d24eaa98c3dc2d118c5d9f0
pkgname = perl-alien-wxwidgets
diff --git a/PKGBUILD b/PKGBUILD
index 7001e57e1d01..51724c6a8d20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Contributor: Swift Geek <swiftgeek «at» gmail.com>
+# Maintainer: Swift Geek <swiftgeek «at» gmail.com>
# Contributor: Nick Østergaard <oe.nick at gmail dot com>
+# Contributor: John D Jones III (jnbek) <jnbek1972 at gmail dot com>
+
pkgname=perl-alien-wxwidgets
+_cpan_name=Alien-wxWidgets
pkgver=0.65
pkgrel=1
pkgdesc="building, finding and using wxWidgets binaries"
arch=('any')
-url="http://search.cpan.org/dist/Alien-wxWidgets"
+url="http://search.cpan.org/dist/${_cpan_name}"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'wxgtk2.8' 'perl-module-pluggable') # Install perl-module-pluggable from AUR
makedepends=()
options=(!emptydirs)
-source=("http://search.cpan.org/CPAN/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-${pkgver}.tar.gz")
+source=("http://www.cpan.org/modules/by-module/${_cpan_name%%-*}/${_cpan_name}-${pkgver}.tar.gz")
md5sums=('219a4f572d24eaa98c3dc2d118c5d9f0')
prepare() {
- export _src_dir="$srcdir/Alien-wxWidgets-$pkgver"
+ export _src_dir="${_cpan_name}-${pkgver}"
# Setting these env variables overwrites any command-line-options we don't want...
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \