summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-02-28 02:23:18 +0100
committerSebastian 'Swift Geek' Grzywna2017-02-28 02:23:18 +0100
commit3525468298ce62bd9c50476e1c35d58c0bb03745 (patch)
tree279c301cd40f8dd372c2bc5851913a3ebcacfef0
parentf21e402cb3dc0023aeacff21df2f341e5fa0d3f6 (diff)
downloadaur-3525468298ce62bd9c50476e1c35d58c0bb03745.tar.gz
Fix use with makepkg -e and -o options
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c162356a739..e2e47db60fd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Feb 23 05:13:05 UTC 2016
+# Tue Feb 28 01:23:18 UTC 2017
pkgbase = perl-alien-wxwidgets
pkgdesc = building, finding and using wxWidgets binaries
pkgver = 0.67
diff --git a/PKGBUILD b/PKGBUILD
index 9c73c8beec24..f8def5d86bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,15 +20,9 @@ source=("http://www.cpan.org/modules/by-module/${_cpan_name%%-*}/${_cpan_name}-$
md5sums=('510a7817fdaf59089b50a877a621d770'
'1d21142e0a60bec1a4fab11dc545f955'
'0011e91d60a7a669426341687cb6a5e2')
+_src_dir='${_cpan_name}-${pkgver}'
-prepare() {
- export _src_dir="${_cpan_name}-${pkgver}"
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- warning "If build stage tries to pull and compile WX - interrupt as resulting package wont work"
+#prepare() {
# warning "If package contains gtk2_3_0_0_uni_gcc_3_4.pm it is an improper package - do not attempt to install it - report in comments instead"
# HAX HAX HAX - hax first in PATH to replace /usr/bin
@@ -40,26 +34,32 @@ prepare() {
# https://rt.cpan.org/Public/Bug/Display.html?id=94367
# https://rt.cpan.org/Public/Bug/Display.html?id=87202
# {
-# cd "$_src_dir"
+# eval cd "$_src_dir"
# patch < ${srcdir}/wx-config-version-and-env.patch
# patch ./lib/Alien/wxWidgets/Utility.pm < ${srcdir}/Alien-wxWidgets-0.64-returnor.patch
# }
-}
+#}
build() {
- cd "$_src_dir"
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ warning "If build stage tries to pull and compile WX - interrupt as resulting package won\'t work"
+ eval cd "$_src_dir"
/usr/bin/perl Makefile.PL
make
}
check () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make test
}
package () {
- cd "$_src_dir"
- echo "$_src_dir"
+ eval cd "$_src_dir"
+ pwd
make install
# remove perllocal.pod and .packlist