summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-09-18 17:16:45 +0200
committerPiotr Rogoża2015-09-18 17:16:45 +0200
commit2f4eb7ad5749ca09d9906ffacc8af1636d92ba83 (patch)
tree9a34020a0f837621a6f2bd6038074ea9c199899a
downloadaur-2f4eb7ad5749ca09d9906ffacc8af1636d92ba83.tar.gz
Initial commit; version 0.07
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD70
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36b8586d71eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-array-diff
+ pkgdesc = Array::Diff - Find the differences between two arrays
+ pkgver = 0.07
+ pkgrel = 1
+ url = http://search.cpan.org/dist/array-diff/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TY/TYPESTER/Array-Diff-0.07.tar.gz
+ sha256sums = 78e7d3a3374c74e117b7198f8e6649367a2906561b8a485d3870f242fa8f8346
+
+pkgname = perl-array-diff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8012597d4ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+
+pkgname=perl-array-diff
+pkgver=0.07
+pkgrel=1
+_author="T/TY/TYPESTER"
+_perlmod="Array-Diff"
+pkgdesc="Array::Diff - Find the differences between two arrays"
+arch=('any')
+url="http://search.cpan.org/dist/array-diff/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+checkdepends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+install=
+noextract=()
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('78e7d3a3374c74e117b7198f8e6649367a2906561b8a485d3870f242fa8f8346')
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+