summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:05:43 -0600
committerJohn D Jones III2015-06-16 14:05:43 -0600
commit889917aa672432e847dae89a70635eb3200e6f08 (patch)
tree74b3b6f87c94f8f7820976309946871fc023fbf1
downloadaur-889917aa672432e847dae89a70635eb3200e6f08.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dacaf005edda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-audio-ecasound
+ pkgdesc = Perl binding to the ecasound sampler, recorder, fx-processor
+ pkgver = 1.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Audio-Ecasound
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BO/BOWMANBS/Audio-Ecasound-1.01.tar.gz
+ md5sums = dfa32c87cfa1fe8432c94c041acd4b09
+ sha512sums = 1201ca722d6810263c3356fa714c9b19e25203118462b34b3114d5f42ec74c4b21ba7dc84ad5f72d6271b3f7bc6ed39aee1103b6d581f89c8ae9fd96c83941f6
+
+pkgname = perl-audio-ecasound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d93d2a7ee3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-audio-ecasound'
+pkgver='1.01'
+pkgrel='1'
+pkgdesc="Perl binding to the ecasound sampler, recorder, fx-processor"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Audio-Ecasound'
+source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOWMANBS/Audio-Ecasound-1.01.tar.gz')
+md5sums=('dfa32c87cfa1fe8432c94c041acd4b09')
+sha512sums=('1201ca722d6810263c3356fa714c9b19e25203118462b34b3114d5f42ec74c4b21ba7dc84ad5f72d6271b3f7bc6ed39aee1103b6d581f89c8ae9fd96c83941f6')
+_distdir="Audio-Ecasound-1.01"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: