summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772015-09-19 14:31:55 +0200
committerThor772015-09-19 14:31:55 +0200
commitdb4eac4e4bf5d3545743e2a859fd7f3aa25b16e5 (patch)
treea0c99457727f6ebfc6958206f8626cd4e420fbc8
downloadaur-db4eac4e4bf5d3545743e2a859fd7f3aa25b16e5.tar.gz
Initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cdc138136f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-audio-flac-header
+ pkgdesc = Audio::FLAC::Header - Access to FLAC audio metadata
+ pkgver = 2.4
+ pkgrel = 8
+ url = http://search.cpan.org/dist/Audio-FLAC-Header
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ options = !emptydirs
+ source = http://cpan.org/modules/by-module/Audio/Audio-FLAC-Header-2.4.tar.gz
+ sha512sums = 53728279b79d3c320c63b66dff1e3e4d8bb4fd4bde164ad775a52d8b54b3d77861daa2d4e93d8e2c2ff2f1708ece8c4d2256d96b810266760bb837e557e3b8a9
+
+pkgname = perl-audio-flac-header
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c6f385fda47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thor77 <thor77 at thor77 dot org>
+# Contributor: Jason St. John <jstjohn .. purdue . edu>
+# Contributor: Justin Davis <jrcd83@gmail.com>
+
+_perlmod=Audio-FLAC-Header
+_modnamespace=Audio
+pkgname=perl-audio-flac-header
+pkgver=2.4
+pkgrel=8
+pkgdesc="Audio::FLAC::Header - Access to FLAC audio metadata"
+arch=('any')
+url="http://search.cpan.org/dist/${_perlmod}"
+license=('GPL' 'PerlArtistic')
+options=('!emptydirs')
+source=("http://cpan.org/modules/by-module/${_modnamespace}/${_perlmod}-${pkgver}.tar.gz")
+sha512sums=('53728279b79d3c320c63b66dff1e3e4d8bb4fd4bde164ad775a52d8b54b3d77861daa2d4e93d8e2c2ff2f1708ece8c4d2256d96b810266760bb837e557e3b8a9')
+
+build() {
+ cd "${_perlmod}-${pkgver}"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${_perlmod}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${_perlmod}-${pkgver}"
+ make install DESTDIR="${pkgdir}/"
+}