summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2018-12-12 15:44:06 +0530
committerAmish2018-12-12 15:44:06 +0530
commit3120fb1711d8d3a527b63233b6f73cc640b3a8bb (patch)
treee68407cb5fb0f9e9c95742e5f885cb4cf9bb5890
parentcb82575b244e31fdc423f3b600b502e7ba81d2b1 (diff)
downloadaur-3120fb1711d8d3a527b63233b6f73cc640b3a8bb.tar.gz
Get rid of patch. Use sed instead for one line change
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
-rw-r--r--dotinc.patch11
3 files changed, 14 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6148c21c1da6..beb440ace9d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-authen-pam
pkgdesc = Perl interface to PAM library
pkgver = 0.16
- pkgrel = 4
+ pkgrel = 5
url = https://metacpan.org/release/Authen-PAM
arch = any
license = GPL
@@ -10,11 +10,8 @@ pkgbase = perl-authen-pam
options = !emptydirs
options = purge
source = https://cpan.metacpan.org/authors/id/N/NI/NIKIP/Authen-PAM-0.16.tar.gz
- source = dotinc.patch
md5sums = 7278471dfa694d9ef312bc92d7099af2
- md5sums = 09fae4f73d80b8cc9acc72105e9109d2
sha512sums = 2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd
- sha512sums = d42c9eeeb740d8fd82d948570bb95a139d82ca404b5df43459cf423006d53f8dfac67e19ee8c8ea9cb3346d9e04a23600b4a8c2e4d9825a9c4db135ccea00b92
pkgname = perl-authen-pam
diff --git a/PKGBUILD b/PKGBUILD
index be67bd330ff0..07ccef747944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=perl-authen-pam
pkgver=0.16
-pkgrel=4
+pkgrel=5
pkgdesc="Perl interface to PAM library"
_dist=Authen-PAM
arch=('any')
@@ -13,16 +13,13 @@ url="https://metacpan.org/release/${_dist}"
license=('GPL' 'PerlArtistic')
depends=('perl')
options=('!emptydirs' purge)
-source=("https://cpan.metacpan.org/authors/id/N/NI/NIKIP/${_dist}-${pkgver}.tar.gz"
- "dotinc.patch")
-md5sums=('7278471dfa694d9ef312bc92d7099af2'
- '09fae4f73d80b8cc9acc72105e9109d2')
-sha512sums=('2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd'
- 'd42c9eeeb740d8fd82d948570bb95a139d82ca404b5df43459cf423006d53f8dfac67e19ee8c8ea9cb3346d9e04a23600b4a8c2e4d9825a9c4db135ccea00b92')
+source=("https://cpan.metacpan.org/authors/id/N/NI/NIKIP/${_dist}-${pkgver}.tar.gz")
+md5sums=('7278471dfa694d9ef312bc92d7099af2')
+sha512sums=('2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd')
prepare() {
cd "${srcdir}/${_dist}-${pkgver}"
- patch -p1 -i ../dotinc.patch
+ sed -i -e 's#require "pam.cfg"#require "./pam.cfg"#g' Makefile.PL
}
build() {
@@ -33,6 +30,14 @@ build() {
make
}
+check() {
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ echo skipped for now as tests asks for user password
+ #make test
+}
+
package() {
cd "${srcdir}/${_dist}-${pkgver}"
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
diff --git a/dotinc.patch b/dotinc.patch
deleted file mode 100644
index 3f20b099a0c8..000000000000
--- a/dotinc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Authen-PAM-0.16/Makefile.PL.orig 2017-06-07 17:12:32.243856974 +0530
-+++ Authen-PAM-0.16/Makefile.PL 2017-06-07 17:12:41.920801639 +0530
-@@ -10,7 +10,7 @@
-
- # returns a reference to anonymous hash which is then interpreted as
- # additional options to the WriteMakeFile
-- $options = require "pam.cfg";
-+ $options = require "./pam.cfg";
-
- if ( $Config{'osname'} eq 'solaris' && $Config{'osvers'} eq '2.6') {
- print "Adding a workaround for a bug in the Solaris 2.6 pam library\n";