summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-06-07 23:20:37 +0200
committerjose17112017-06-07 23:20:37 +0200
commitce75923c6dba1aea1bbe3c3fb97463dfead54635 (patch)
tree72f6b94ab205a332fdb92d8a94b044f250231761
parent2105232d5d6eeb365274a0630d163634f3261654 (diff)
downloadaur-ce75923c6dba1aea1bbe3c3fb97463dfead54635.tar.gz
Add patch for Perl 5.26 (thanks @amish)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--dotinc.patch11
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcd34fdad113..50791490d827 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Jul 25 05:41:24 UTC 2016
+# Wed Jun 7 21:20:17 UTC 2017
pkgbase = perl-authen-pam
pkgdesc = Perl interface to PAM library
pkgver = 0.16
- pkgrel = 2
+ pkgrel = 3
url = http://search.cpan.org/~nikip/Authen-PAM-0.16/
arch = any
license = unknown
depends = perl
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-0.16.tar.gz
+ source = dotinc.patch
md5sums = 7278471dfa694d9ef312bc92d7099af2
+ md5sums = 09fae4f73d80b8cc9acc72105e9109d2
pkgname = perl-authen-pam
diff --git a/PKGBUILD b/PKGBUILD
index e6a054966f80..9c9da86909eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# CPAN Name : Authen-Simple-LDAP
# Maintainer: Jose Riha <jose1711 gmail com>
# Contributor: Christian Hesse <mail@earthworm.de>
+# Contributor: amish
pkgname='perl-authen-pam'
pkgver='0.16'
-pkgrel='2'
+pkgrel='3'
pkgdesc="Perl interface to PAM library"
arch=('any')
url="http://search.cpan.org/~nikip/Authen-PAM-$pkgver/"
@@ -13,8 +14,15 @@ depends=('perl')
options=('!emptydirs')
-source=("http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-$pkgver.tar.gz")
-md5sums=('7278471dfa694d9ef312bc92d7099af2')
+source=("http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-$pkgver.tar.gz"
+ "dotinc.patch")
+md5sums=('7278471dfa694d9ef312bc92d7099af2'
+ '09fae4f73d80b8cc9acc72105e9109d2')
+
+prepare() {
+cd ${srcdir}/Authen-PAM-$pkgver
+patch -p1 -i ../dotinc.patch
+}
build() {
cd ${srcdir}/Authen-PAM-$pkgver
diff --git a/dotinc.patch b/dotinc.patch
new file mode 100644
index 000000000000..3f20b099a0c8
--- /dev/null
+++ b/dotinc.patch
@@ -0,0 +1,11 @@
+--- Authen-PAM-0.16/Makefile.PL.orig 2017-06-07 17:12:32.243856974 +0530
++++ Authen-PAM-0.16/Makefile.PL 2017-06-07 17:12:41.920801639 +0530
+@@ -10,7 +10,7 @@
+
+ # returns a reference to anonymous hash which is then interpreted as
+ # additional options to the WriteMakeFile
+- $options = require "pam.cfg";
++ $options = require "./pam.cfg";
+
+ if ( $Config{'osname'} eq 'solaris' && $Config{'osvers'} eq '2.6') {
+ print "Adding a workaround for a bug in the Solaris 2.6 pam library\n";