summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:06:14 -0600
committerJohn D Jones III2015-06-16 14:06:14 -0600
commitebf74b1df33ec744e4b1eb6ebe23f6a8cfb891df (patch)
tree1ef66555bb9473945efd0884ce82a725aafea71b
downloadaur-ebf74b1df33ec744e4b1eb6ebe23f6a8cfb891df.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5232ce28495
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-authen-sasl-saslprep
+ pkgdesc = A Stringprep Profile for User Names and Passwords (RFC 4013)
+ pkgver = 1.01
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Authen-SASL-SASLprep
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-nowarnings
+ depends = perl-unicode-stringprep>=1
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/C/CF/CFAERBER/Authen-SASL-SASLprep-1.01.tar.gz
+ md5sums = e1b800b47e360912c382e764c10a58c9
+ sha512sums = 62b22ba627e6e41c5db1579ffc1270a964f7e0a0e73292abf844f30057f8a77384138150feadc8d84fe8f6ab765bfb38b85c011db2cdcc72cc7d9db92440a3b4
+
+pkgname = perl-authen-sasl-saslprep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47946bbf9c8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-authen-sasl-saslprep'
+pkgver='1.01'
+pkgrel='1'
+pkgdesc="A Stringprep Profile for User Names and Passwords (RFC 4013)"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-unicode-stringprep>=1')
+makedepends=()
+checkdepends=('perl-test-nowarnings')
+url='http://search.mcpan.org/dist/Authen-SASL-SASLprep'
+source=('http://search.mcpan.org/CPAN/authors/id/C/CF/CFAERBER/Authen-SASL-SASLprep-1.01.tar.gz')
+md5sums=('e1b800b47e360912c382e764c10a58c9')
+sha512sums=('62b22ba627e6e41c5db1579ffc1270a964f7e0a0e73292abf844f30057f8a77384138150feadc8d84fe8f6ab765bfb38b85c011db2cdcc72cc7d9db92440a3b4')
+_distdir="Authen-SASL-SASLprep-1.01"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: