summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPappy STĂNESCU2016-10-03 18:23:54 +0300
committerPappy STĂNESCU2016-10-03 18:23:54 +0300
commita00c0021568a2e0565d4188fc7e37348c0b3b245 (patch)
tree569bd4c794a4db87e3e23c8579684aed342d07d3
downloadaur-a00c0021568a2e0565d4188fc7e37348c0b3b245.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0868d16e88a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = perl-authen-simple-radius
+ pkgdesc = Simple RADIUS authentication
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://search.cpan.org/~chansen/Authen-Simple-RADIUS-0.1
+ arch = any
+ depends = perl-authen-radius
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CH/CHANSEN/Authen-Simple-RADIUS-0.1.tar.gz
+ md5sums = e5a5bc72f2b8f8fe0e5a9eff085e23b2
+
+pkgname = perl-authen-simple-radius
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5624b74f804
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1535b4c26547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pappy STĂNESCU <pappy _AT_ a s c e l i o n _DOT_ com>
+
+_cpan_name=Authen-Simple-RADIUS
+_cpan_desc='Simple RADIUS authentication'
+_cpan_author=chansen
+_cpan_version=0.1
+_cpan_md5=e5a5bc72f2b8f8fe0e5a9eff085e23b2
+
+pkgrel=1
+pkgname=perl-${_cpan_name,,}
+pkgdesc=$_cpan_desc
+pkgver=$_cpan_version
+md5sums=($_cpan_md5)
+depends=('perl-authen-radius')
+makedepends=('')
+checkdepends=()
+
+_cpan_path=${_cpan_author:0:1}/${_cpan_author:0:2}/${_cpan_author}
+
+url="http://search.cpan.org/~${_cpan_author}/${_cpan_name}-$pkgver"
+source=("http://search.cpan.org/CPAN/authors/id/${_cpan_path^^}/${_cpan_name}-$pkgver.tar.gz")
+options=(!emptydirs)
+arch=('any')
+
+build() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ make install DESTDIR=$pkgdir
+}
+