summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-09-10 00:40:09 -0300
committerThiago L. A. Miller2018-09-10 00:40:09 -0300
commit363ec8d9630a92d793bbe0f681bf3ab27e430aa9 (patch)
treeea1a8a8e3ec737d99f55a3e59245940a7b1d950b
parent3d3823c2311e5d10036bf6f74c5c9a87ac7adfbc (diff)
downloadaur-363ec8d9630a92d793bbe0f681bf3ab27e430aa9.tar.gz
Update to version 1.33
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bde2158e8bfe..922e59fa9c84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = perl-autobox-core
- pkgdesc = Provide core functions to autoboxed scalars, arrays and hashes.
- pkgver = 1.29
+ pkgdesc = Provide core functions to autoboxed scalars, arrays and hashes
+ pkgver = 1.33
pkgrel = 1
- url = http://search.cpan.org/dist/autobox-Core
+ url = https://metacpan.org/release/autobox-Core
arch = any
license = PerlArtistic
license = GPL
+ depends = perl-want>=0.26
depends = perl-autobox>=2.71
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/X/XE/XENU/autobox-Core-1.29.tar.gz
- md5sums = 10b0f4c908542e034a2a423a358ab420
+ source = http://search.cpan.org/CPAN/authors/id/S/SW/SWALTERS/autobox-Core-1.33.tar.gz
+ md5sums = a7779011d27b04229ec912841ef40fff
pkgname = perl-autobox-core
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e20245338b32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 712ee592ac96..9b2a490b00ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
# Contributor: Mateusz Krasowski <matkras@gmail.com>
-# Generator : CPANPLUS::Dist::Arch 1.25
-
-pkgname='perl-autobox-core'
-pkgver='1.29'
-pkgrel='1'
-pkgdesc="Provide core functions to autoboxed scalars, arrays and hashes."
+_distname=autobox-Core
+pkgname=perl-autobox-core
+pkgver=1.33
+pkgrel=1
+pkgdesc="Provide core functions to autoboxed scalars, arrays and hashes"
arch=('any')
+url="https://metacpan.org/release/$_distname"
license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl-autobox>=2.71')
+depends=('perl-want>=0.26' 'perl-autobox>=2.71')
makedepends=()
-url='http://search.cpan.org/dist/autobox-Core'
-source=('http://search.cpan.org/CPAN/authors/id/X/XE/XENU/autobox-Core-1.29.tar.gz')
-md5sums=('10b0f4c908542e034a2a423a358ab420')
-_distdir="autobox-Core-1.29"
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/S/SW/SWALTERS/$_distname-$pkgver.tar.gz")
+md5sums=('a7779011d27b04229ec912841ef40fff')
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -22,21 +21,21 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
make install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}