summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2019-08-20 11:28:41 +0300
committerAnton Leontiev2019-08-20 11:28:47 +0300
commit23f812c89ac3147ec9e0289072106fa03ade9464 (patch)
tree4872cad94f3170484b15b59a4cc284b14ea9679a
parent6d141405029158cdcf6a3c215bb0216430f9a9f5 (diff)
downloadaur-perl-b-hooks-op-annotation.tar.gz
Sanitize environment and fix command to remove .packlist and perllocal.pod
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD42
-rw-r--r--PKGBUILD.tt36
3 files changed, 49 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cb2d6f07323..590882f39eb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-b-hooks-op-annotation
pkgdesc = Perl module that allows XS modules to annotate and delegate hooked OPs
pkgver = 0.44
- pkgrel = 1
- url = http://search.cpan.org/dist/B-Hooks-OP-Annotation
+ pkgrel = 2
+ url = https://metacpan.org/release/B-Hooks-OP-Annotation
arch = i686
arch = x86_64
license = PerlArtistic
diff --git a/PKGBUILD b/PKGBUILD
index 02a97d5cf69f..5fb48576f88e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
# CPAN Name : B::Hooks::OP::Annotation
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.19
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-b-hooks-op-annotation
pkgver=0.44
-pkgrel=1
-pkgdesc="Perl module that allows XS modules to annotate and delegate hooked OPs"
-arch=("i686" "x86_64")
-url="http://search.cpan.org/dist/B-Hooks-OP-Annotation"
-license=("PerlArtistic" "GPL")
-depends=("perl" "perl-extutils-depends>=0.304")
+pkgrel=2
+pkgdesc='Perl module that allows XS modules to annotate and delegate hooked OPs'
+arch=('i686' 'x86_64')
+url='https://metacpan.org/release/B-Hooks-OP-Annotation'
+license=('PerlArtistic' 'GPL')
+depends=('perl' 'perl-extutils-depends>=0.304')
source=(http://search.cpan.org/CPAN/authors/id/C/CH/CHOCOLATE/B-Hooks-OP-Annotation-0.44.tar.gz)
options=(!emptydirs)
-md5sums=("18b1f0088850effe58ccb4a7c9dc4024")
+md5sums=('18b1f0088850effe58ccb4a7c9dc4024')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
build() {
- cd "$srcdir/B-Hooks-OP-Annotation-0.44"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd B-Hooks-OP-Annotation-0.44
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/B-Hooks-OP-Annotation-0.44"
- make test
+ cd B-Hooks-OP-Annotation-0.44
+ sanitize
+ make test
}
package() {
- cd "$srcdir/B-Hooks-OP-Annotation-0.44"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd B-Hooks-OP-Annotation-0.44
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 5bf321f45f9b..deb712402766 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -5,28 +5,36 @@
pkgname=[% pkgname %]
pkgver=[% pkgver %]
pkgrel=[% pkgrel %]
-pkgdesc="Perl module that allows XS modules to annotate and delegate hooked OPs"
-arch=("i686" "x86_64")
-url="[% url %]"
-license=("PerlArtistic" "GPL")
-depends=("perl" "perl-extutils-depends>=0.304")
+pkgdesc='Perl module that allows XS modules to annotate and delegate hooked OPs'
+arch=('i686' 'x86_64')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl' 'perl-extutils-depends>=0.304')
source=([% source %])
options=(!emptydirs)
-md5sums=("[% md5sums %]")
+md5sums=('[% md5sums %]')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
build() {
- cd "$srcdir/[% distdir %]"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd [% distdir %]
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/[% distdir %]"
- make test
+ cd [% distdir %]
+ sanitize
+ make test
}
package() {
- cd "$srcdir/[% distdir %]"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd [% distdir %]
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}