summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-09-13 11:37:03 +0200
committerint2017-09-13 11:37:03 +0200
commite658e9501eaa8164c2c49f811d9a1d5ceedcb910 (patch)
tree734344c692f9de4dfbc04426a0c0cce91c560d3b
downloadaur-e658e9501eaa8164c2c49f811d9a1d5ceedcb910.tar.gz
Added perl CPAN-module Barcode::Code128.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..897b70eaa38d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 5.0.1
+# Sun May 21 21:54:33 UTC 2017
+pkgbase = perl-barcode-code128
+ pkgdesc = Generate CODE 128 bar codes
+ pkgver = 2.21
+ pkgrel = 1
+ url = https://metacpan.org/release/Barcode-Code128
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/W/WR/WRW/Barcode-Code128-2.21.tar.gz
+ md5sums = 27cf162cb919445ba916ce347e6a2936
+ sha512sums = 64ca60529d6a99fe73757739a3535da279006c0002c8d7d6e8d27f71511dc92db6c85bb55031fd74bff1fb9e80e623a625bfb373e682daca02c8670d51d819aa
+
+pkgname = perl-barcode-code128
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e5d4368b18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-barcode-code128'
+pkgver='2.21'
+pkgrel='1'
+pkgdesc="Generate CODE 128 bar codes"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Barcode-Code128'
+source=('http://search.cpan.org/CPAN/authors/id/W/WR/WRW/Barcode-Code128-2.21.tar.gz')
+md5sums=('27cf162cb919445ba916ce347e6a2936')
+sha512sums=('64ca60529d6a99fe73757739a3535da279006c0002c8d7d6e8d27f71511dc92db6c85bb55031fd74bff1fb9e80e623a625bfb373e682daca02c8670d51d819aa')
+_distdir="Barcode-Code128-2.21"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: