summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:04:42 +0200
committerPiotr Rogoża2015-06-14 16:04:42 +0200
commitb0e59a6ca2e86c9dd21dfbb1b0c98c2b4adf87e5 (patch)
tree20e3712ecd44e4753f50cb8c8f4867d91cfccae3
downloadaur-b0e59a6ca2e86c9dd21dfbb1b0c98c2b4adf87e5.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD68
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfe065d014bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-bash-completion-plugins-cpanm
+ pkgdesc = Bash::Completion::Plugins::cpanm - Bash completion for cpanm and cpanf
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Bash-Completion-Plugins-cpanm/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-bash-completion
+ depends = perl-http-message
+ depends = perl-json
+ depends = perl-libwww
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PE/PERLER/Bash-Completion-Plugins-cpanm-0.0.2.tar.gz
+ md5sums = ba7d72454c84f94e93713423661929fb
+
+pkgname = perl-bash-completion-plugins-cpanm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5a4864fc017
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-bash-completion-plugins-cpanm
+pkgver=0.0.2
+pkgrel=1
+_author="P/PE/PERLER"
+_perlmod="Bash-Completion-Plugins-cpanm"
+pkgdesc="Bash::Completion::Plugins::cpanm - Bash completion for cpanm and cpanf"
+arch=('any')
+url="http://search.cpan.org/dist/Bash-Completion-Plugins-cpanm/"
+license=('GPL' 'PerlArtistic')
+depends=(
+perl-bash-completion
+perl-http-message
+perl-json
+perl-libwww
+)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('ba7d72454c84f94e93713423661929fb')