summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergan Penkov2015-08-09 16:47:01 +0200
committerGergan Penkov2015-08-09 16:47:01 +0200
commit7b35c9af866c3b399fe3835fcbdd0e9bedab0c74 (patch)
treef46bbaace0146137286f82d23e9c3370780f5d93
downloadaur-7b35c9af866c3b399fe3835fcbdd0e9bedab0c74.tar.gz
created with CPANPLUS::Dist::Arch
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD50
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f82aae359756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.1
+# Sun Aug 9 14:39:14 UTC 2015
+pkgbase = perl-catalyst-authentication-credential-http
+ pkgdesc = HTTP Basic and Digest authentication
+ pkgver = 1.016
+ pkgrel = 1
+ url = https://metacpan.org/release/Catalyst-Authentication-Credential-HTTP
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-exception>=0
+ checkdepends = perl-test-mockobject>=0
+ depends = perl-catalyst-plugin-authentication>=0.10005
+ depends = perl-catalyst-runtime>=0
+ depends = perl-class-accessor>=0
+ depends = perl-data-uuid>=0.11
+ depends = perl-string-escape>=0
+ depends = perl-uri>=0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/Catalyst-Authentication-Credential-HTTP-1.016.tar.gz
+ md5sums = 65b5f09e7e3e46370b67b39922760b8e
+ sha512sums = 76285e217ecc9ec05f09451209a04843851d7c125e784408e55a0a671886f2bdec9ab36c528ded07d26c28ea389a58b6d24915530f08dd40687c83fd2a4c4509
+
+pkgname = perl-catalyst-authentication-credential-http
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b09070062239
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: GPP <gergan@gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-catalyst-authentication-credential-http'
+pkgver='1.016'
+pkgrel='1'
+pkgdesc="HTTP Basic and Digest authentication"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-catalyst-plugin-authentication>=0.10005' 'perl-catalyst-runtime>=0' 'perl-class-accessor>=0' 'perl-data-uuid>=0.11' 'perl-string-escape>=0' 'perl-uri>=0')
+makedepends=()
+checkdepends=('perl-test-exception>=0' 'perl-test-mockobject>=0')
+url='https://metacpan.org/release/Catalyst-Authentication-Credential-HTTP'
+source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/Catalyst-Authentication-Credential-HTTP-1.016.tar.gz')
+md5sums=('65b5f09e7e3e46370b67b39922760b8e')
+sha512sums=('76285e217ecc9ec05f09451209a04843851d7c125e784408e55a0a671886f2bdec9ab36c528ded07d26c28ea389a58b6d24915530f08dd40687c83fd2a4c4509')
+_distdir="Catalyst-Authentication-Credential-HTTP-1.016"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: