summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien2018-10-17 22:40:19 +0200
committerDamien2018-10-24 17:22:28 +0200
commiteaf9d271a2b3a53c2520769905274abf7d356f0c (patch)
tree2a631314e65bc820e61e47cf562436a3b51d274b
downloadaur-eaf9d271a2b3a53c2520769905274abf7d356f0c.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD43
-rw-r--r--kill-canary.patch19
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9313451b59ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-cbor-xs
+ pkgdesc = Concise Binary Object Representation
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://metacpan.org/release/CBOR-XS
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = perl
+ depends = perl-types-serialiser
+ depends = perl-common-sense
+ options = !emptydirs
+ source = https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/CBOR-XS-1.7.tar.gz
+ source = kill-canary.patch
+ sha512sums = 13f5a0db0e983929fe7a670caf23ef130ed18f1974cf471d77d20e9e5d78c8afcad9a3440f198906d8e30625da7f8cb1d3a8919fd896442101f3865f0af5614c
+ sha512sums = 930bea1d5cfad6bfdf09db9a6532ce4eb584adda3182d34d00f547bc918a0c9eb7cefbd2ace5a8eb7acda9275f4143961b0581747d6cc795988891e99c638ead
+
+pkgname = perl-cbor-xs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..af195f62f0a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+CBOR-XS-*.tar.gz
+perl-cbor-xs-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..343e6ffb8618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Damien Molinier <damien-43\N{COMMERCIAL AT}gmx.fr>
+
+pkgname=perl-cbor-xs
+pkgver=1.7
+pkgrel=1
+pkgdesc="Concise Binary Object Representation"
+arch=('x86_64' 'i686')
+license=('GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-types-serialiser' 'perl-common-sense')
+url='https://metacpan.org/release/CBOR-XS'
+source=("https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/CBOR-XS-${pkgver}.tar.gz"
+ "kill-canary.patch")
+sha512sums=('13f5a0db0e983929fe7a670caf23ef130ed18f1974cf471d77d20e9e5d78c8afcad9a3440f198906d8e30625da7f8cb1d3a8919fd896442101f3865f0af5614c'
+ '930bea1d5cfad6bfdf09db9a6532ce4eb584adda3182d34d00f547bc918a0c9eb7cefbd2ace5a8eb7acda9275f4143961b0581747d6cc795988891e99c638ead')
+
+_distdir="CBOR-XS-${pkgver}"
+
+prepare() {
+ cd "${srcdir}/${_distdir}"
+ patch -p1 <"${srcdir}/kill-canary.patch"
+}
+
+build() {
+ cd "${srcdir}/${_distdir}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ perl Makefile.PL INSTALLDIRS='vendor'
+ make
+}
+
+check() {
+ cd "${srcdir}/${_distdir}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_distdir}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ make install DESTDIR="${pkgdir}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/kill-canary.patch b/kill-canary.patch
new file mode 100644
index 000000000000..0ab52524e5f2
--- /dev/null
+++ b/kill-canary.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,8 +1,6 @@
+ use 5.010001; # for utf-8, and Time::Piece
+ use ExtUtils::MakeMaker;
+
+-use Canary::Stability CBOR::XS => 1, 5.010001;
+-
+ WriteMakefile(
+ dist => {
+ PREOP => 'pod2text XS.pm | tee README >$(DISTVNAME)/README; chmod -R u=rwX,go=rX . ;',
+@@ -15,6 +13,6 @@
+ common::sense => 0,
+ Types::Serialiser => 0,
+ },
+- CONFIGURE_REQUIRES => { ExtUtils::MakeMaker => 6.52, Canary::Stability => 0 },
++ CONFIGURE_REQUIRES => { ExtUtils::MakeMaker => 6.52 },
+ );
+