summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2015-06-08 11:58:53 +0200
committerJonne Haß2015-06-08 11:58:53 +0200
commit6790efe30533ad7c623694d25f01eea9bd429355 (patch)
treed79ab4ab28b5e0425ab1367f6263fb8099fe6f84
downloadaur-6790efe30533ad7c623694d25f01eea9bd429355.tar.gz
add perl-cgi-application-plugin-authentication
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..224dbec87865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-cgi-application-plugin-authentication
+ pkgdesc = CGI::Application::Plugin::Authentication - Authentication framework for CGI::Application
+ pkgver = 0.20
+ pkgrel = 1
+ url = http://search.cpan.org/~silasmonk/CGI-Application-Plugin-Authentication-0.20/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = perl-cgi-application
+ options = !emptydirs
+ source = http://cpan.perl.org/modules/by-authors/id/S/SI/SILASMONK/CGI-Application-Plugin-Authentication-0.20.tar.gz
+ md5sums = 5b4ff96b2f703b11bae13308aee7bd30
+
+pkgname = perl-cgi-application-plugin-authentication
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84779860d200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jonne Haß <me@mrzyx.de>
+_author="silasmonk"
+_perlmod="CGI-Application-Plugin-Authentication"
+pkgname=perl-cgi-application-plugin-authentication
+pkgver=0.20
+pkgrel=1
+pkgdesc="CGI::Application::Plugin::Authentication - Authentication framework for CGI::Application"
+arch=('any')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'perl-cgi-application')
+options=(!emptydirs)
+source=(http://cpan.perl.org/modules/by-authors/id/S/SI/SILASMONK/$_perlmod-$pkgver.tar.gz)
+md5sums=('5b4ff96b2f703b11bae13308aee7bd30')
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ perl Build.PL installdirs=vendor destdir="$pkgdir/"
+ perl Build
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ perl Build install
+}
+
+# vim:set ts=2 sw=2 et: