summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-04-12 09:09:35 +0400
committerAnton Leontiev2015-02-15 07:48:21 +0300
commit78f808be96770e4702190e22039ad3206934d63a (patch)
treee52fc99dacf22cfb7348830b456063009cf15f7c
parent828f947ec61ecb3a682f86b8ad21ef6e53e85bb5 (diff)
downloadaur-78f808be96770e4702190e22039ad3206934d63a.tar.gz
Updated to v4.04
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD37
-rw-r--r--PKGBUILD.tt31
3 files changed, 36 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 804760d562b7..174be609562c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-cgi-application-plugin-dbh
pkgdesc = Perl package for easy DBI access from CGI::Application
- pkgver = 4.01
+ pkgver = 4.04
pkgrel = 1
url = http://search.cpan.org/dist/CGI-Application-Plugin-DBH
arch = any
@@ -8,13 +8,12 @@ pkgbase = perl-cgi-application-plugin-dbh
license = GPL
checkdepends = perl-test-mockobject>=1.20120301
checkdepends = perl-dbd-mock>=0.11
- makedepends = perl
depends = perl>=5.10.1
depends = perl-cgi-application
depends = perl-dbi
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-Plugin-DBH-4.01.tar.gz
- md5sums = ca72a77ad5ec453459db4b1e418ca0de
+ source = http://search.cpan.org/CPAN/authors/id/F/FR/FREW/CGI-Application-Plugin-DBH-4.04.tar.gz
+ md5sums = da6d7bc3b084624fffadd34834f71f77
pkgname = perl-cgi-application-plugin-dbh
diff --git a/PKGBUILD b/PKGBUILD
index fd0b6a2c9da7..f46a2fff7597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,33 @@
# CPAN Name : CGI::Application::Plugin::DBH
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.28
pkgname=perl-cgi-application-plugin-dbh
-pkgver=4.01
+pkgver=4.04
pkgrel=1
-pkgdesc="Perl package for easy DBI access from CGI::Application"
-arch=("any")
-url="http://search.cpan.org/dist/CGI-Application-Plugin-DBH"
-license=("PerlArtistic" "GPL")
-depends=("perl>=5.10.1" "perl-cgi-application" "perl-dbi")
-checkdepends=("perl-test-mockobject>=1.20120301" "perl-dbd-mock>=0.11")
-makedepends=("perl")
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-Plugin-DBH-4.01.tar.gz)
+pkgdesc='Perl package for easy DBI access from CGI::Application'
+arch=('any')
+url='http://search.cpan.org/dist/CGI-Application-Plugin-DBH'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.1' 'perl-cgi-application' 'perl-dbi')
+checkdepends=('perl-test-mockobject>=1.20120301' 'perl-dbd-mock>=0.11')
+source=(http://search.cpan.org/CPAN/authors/id/F/FR/FREW/CGI-Application-Plugin-DBH-4.04.tar.gz)
options=(!emptydirs)
-md5sums=("ca72a77ad5ec453459db4b1e418ca0de")
+md5sums=('da6d7bc3b084624fffadd34834f71f77')
build() {
- cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd CGI-Application-Plugin-DBH-4.04
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
- make test
+ cd CGI-Application-Plugin-DBH-4.04
+ make test
}
package() {
- cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd CGI-Application-Plugin-DBH-4.04
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 789b6857c3bd..af33fc3065b5 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -5,30 +5,29 @@
pkgname=[% pkgname %]
pkgver=[% pkgver %]
pkgrel=[% pkgrel %]
-pkgdesc="Perl package for easy DBI access from CGI::Application"
-arch=("any")
-url="[% url %]"
-license=("PerlArtistic" "GPL")
-depends=("perl>=5.10.1" "perl-cgi-application" "perl-dbi")
-checkdepends=("perl-test-mockobject>=1.20120301" "perl-dbd-mock>=0.11")
-makedepends=("perl")
+pkgdesc='Perl package for easy DBI access from CGI::Application'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.1' 'perl-cgi-application' 'perl-dbi')
+checkdepends=('perl-test-mockobject>=1.20120301' 'perl-dbd-mock>=0.11')
source=([% source %])
options=(!emptydirs)
-md5sums=("[% md5sums %]")
+md5sums=('[% md5sums %]')
build() {
- cd "$srcdir/[% distdir %]"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/[% distdir %]"
- make test
+ cd [% distdir %]
+ make test
}
package() {
- cd "$srcdir/[% distdir %]"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}