summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit828f947ec61ecb3a682f86b8ad21ef6e53e85bb5 (patch)
tree6cc6d3d34487dfa452ba39f478efe486cabc60ba
downloadaur-828f947ec61ecb3a682f86b8ad21ef6e53e85bb5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD34
-rw-r--r--PKGBUILD.tt34
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..804760d562b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-cgi-application-plugin-dbh
+ pkgdesc = Perl package for easy DBI access from CGI::Application
+ pkgver = 4.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/CGI-Application-Plugin-DBH
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-mockobject>=1.20120301
+ checkdepends = perl-dbd-mock>=0.11
+ makedepends = perl
+ depends = perl>=5.10.1
+ depends = perl-cgi-application
+ depends = perl-dbi
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-Plugin-DBH-4.01.tar.gz
+ md5sums = ca72a77ad5ec453459db4b1e418ca0de
+
+pkgname = perl-cgi-application-plugin-dbh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd0b6a2c9da7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# CPAN Name : CGI::Application::Plugin::DBH
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname=perl-cgi-application-plugin-dbh
+pkgver=4.01
+pkgrel=1
+pkgdesc="Perl package for easy DBI access from CGI::Application"
+arch=("any")
+url="http://search.cpan.org/dist/CGI-Application-Plugin-DBH"
+license=("PerlArtistic" "GPL")
+depends=("perl>=5.10.1" "perl-cgi-application" "perl-dbi")
+checkdepends=("perl-test-mockobject>=1.20120301" "perl-dbd-mock>=0.11")
+makedepends=("perl")
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-Plugin-DBH-4.01.tar.gz)
+options=(!emptydirs)
+md5sums=("ca72a77ad5ec453459db4b1e418ca0de")
+
+build() {
+ cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
+ make test
+}
+
+package() {
+ cd "$srcdir/CGI-Application-Plugin-DBH-4.01"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..789b6857c3bd
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,34 @@
+# CPAN Name : CGI::Application::Plugin::DBH
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc="Perl package for easy DBI access from CGI::Application"
+arch=("any")
+url="[% url %]"
+license=("PerlArtistic" "GPL")
+depends=("perl>=5.10.1" "perl-cgi-application" "perl-dbi")
+checkdepends=("perl-test-mockobject>=1.20120301" "perl-dbd-mock>=0.11")
+makedepends=("perl")
+source=([% source %])
+options=(!emptydirs)
+md5sums=("[% md5sums %]")
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}