summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2015-06-08 11:58:53 +0200
committerJonne Haß2015-06-08 11:58:53 +0200
commit3fabc420e417cb25ed6be08e4dbe711034ce066a (patch)
tree7e9ee68bcce33a22cb283d1ed6fedd891cc064d2
downloadaur-3fabc420e417cb25ed6be08e4dbe711034ce066a.tar.gz
add perl-cgi-application-plugin-requiressl
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd7070d0dfc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-cgi-application-plugin-requiressl
+ pkgdesc = CGI::Application::Plugin::RequireSSL - Force SSL in specified pages or modules
+ pkgver = 0.04
+ pkgrel = 1
+ url = http://search.cpan.org/~dhorne/CGI-Application-Plugin-RequireSSL-0.04/
+ arch = any
+ license = unknown
+ depends = perl>=5.10.0
+ depends = perl-cgi-application
+ options = !emptydirs
+ source = http://cpan.perl.org/modules/by-authors/id/D/DH/DHORNE/CGI-Application-Plugin-RequireSSL-0.04.tar.gz
+ md5sums = ffa4fbe3014ded658dc796aafc01a5f8
+
+pkgname = perl-cgi-application-plugin-requiressl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c496658a927
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonne Haß <me@mrzyx.de>
+_author="dhorne"
+_perlmod="CGI-Application-Plugin-RequireSSL"
+pkgname=perl-cgi-application-plugin-requiressl
+pkgver=0.04
+pkgrel=1
+pkgdesc="CGI::Application::Plugin::RequireSSL - Force SSL in specified pages or modules"
+arch=('any')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('unknown')
+depends=('perl>=5.10.0' 'perl-cgi-application')
+options=(!emptydirs)
+source=(http://cpan.perl.org/modules/by-authors/id/D/DH/DHORNE/$_perlmod-$pkgver.tar.gz)
+md5sums=('ffa4fbe3014ded658dc796aafc01a5f8')
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: