summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2016-07-05 17:34:21 +0200
committerRubenKelevra2016-07-05 17:34:21 +0200
commitf2796ddd4188fdb5ed9230b0e6cb79c9c826df7b (patch)
tree71d3f20b43694988578ffba05dd85b500a1ee4d6
downloadaur-f2796ddd4188fdb5ed9230b0e6cb79c9c826df7b.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9efbcb0de109
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 15:34:15 UTC 2016
+pkgbase = perl-cgi-psgi
+ pkgdesc = Adapt CGI.pm to the PSGI protocol
+ pkgver = 0.15
+ pkgrel = 2
+ url = http://search.cpan.org/~miyagawa/CGI-PSGI-0.15/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/CGI-PSGI-0.15.tar.gz
+ sha256sums = c50dcb10bf8486a9843baed032ad89d879ff2f41c993342dead62f947a598d91
+
+pkgname = perl-cgi-psgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4677aa01e9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Max Pray a.k.a. Synthead <synthead@gmail.com>
+# Maintainer: Ruben Kelevra <ruben@vfn-nrw.de>
+
+pkgname=perl-cgi-psgi
+_cpanname="CGI-PSGI"
+pkgver=0.15
+pkgrel=2
+pkgdesc="Adapt CGI.pm to the PSGI protocol"
+arch=('any')
+url="http://search.cpan.org/~miyagawa/$_cpanname-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/$_cpanname-$pkgver.tar.gz")
+sha256sums=('c50dcb10bf8486a9843baed032ad89d879ff2f41c993342dead62f947a598d91')
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}