summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-04-24 13:12:56 -0600
committerJohn D Jones III2016-04-24 13:12:56 -0600
commitbf346560561519c58702bcdc4acefd66672bd5c7 (patch)
treea08b8beaaec4f53eb0524f34d42e43c13c3f063f
downloadaur-bf346560561519c58702bcdc4acefd66672bd5c7.tar.gz
Recommit this
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e50d3d3f3c5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Apr 24 19:12:40 UTC 2016
+pkgbase = perl-class-c3
+ pkgdesc = A pragma to use the C3 method resolution order algorithm
+ pkgver = 0.31
+ pkgrel = 1
+ url = https://metacpan.org/release/Class-C3
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-algorithm-c3>=0.07
+ depends = perl>=5.006
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/Class-C3-0.31.tar.gz
+ md5sums = 81b5258e533d737086d8bc36b869dd90
+ sha512sums = f299e69e6ecfb51536babe89994a66e44179583c1e43cb79e23072f82db35ca3d2cabbc8119bdd59ed7d2119337ada79e55338a6d7b8509a40ea7896cd7f6173
+
+pkgname = perl-class-c3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53e4fc379361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-class-c3'
+pkgver='0.31'
+pkgrel='1'
+pkgdesc="A pragma to use the C3 method resolution order algorithm"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-algorithm-c3>=0.07' 'perl>=5.006')
+makedepends=()
+url='https://metacpan.org/release/Class-C3'
+source=('http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/Class-C3-0.31.tar.gz')
+md5sums=('81b5258e533d737086d8bc36b869dd90')
+sha512sums=('f299e69e6ecfb51536babe89994a66e44179583c1e43cb79e23072f82db35ca3d2cabbc8119bdd59ed7d2119337ada79e55338a6d7b8509a40ea7896cd7f6173')
+_distdir="Class-C3-0.31"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: